Windows and Android cannot see each other. (Is this a bug?)

There are multiple forum posts about people whose who have a Windows device and in addition an Android phone, and who find that that, regularly but intermittently, neither device can see the other (i.e, Syncthing shows ‘disconnected’). I have that problem. Note though that my Android phone syncs unproblematically, via Syncthing, with my Linux laptops. That is: the problem is between Windows and Android.

Things that I have tried to no avail

  • Disabling my Windows PC’s VPN.
  • Disabling my Windows firewall.
  • Ensuring that my Windows network is set, via a Windows setting, to ‘private’.
  • Enabling UP&P on my router. (My routers runs DD-WRT and I have tried more than one build of DD-WRT and so doing does not solve the problem. Also, this problem is fairly new, and I was running DD-WRT when, previously everything worked.)
  • On Android, giving a fixed IP address (which is set by my router) to Syncthing.


  • Windows: 10 Pro - 22H2 (2009: 19045)
  • Syncthing on Windows (which is the latest release): 1.23.6
  • Android: 13.
  • Syncthing on Android (which is the latest release): 1.23.5

Have you tweaked any of the Syncthing settings or are you running with the defaults? Just for the record, local discovery is broken on Android so there may be problems with finding the device if you disable global discovery. This is a well known issue at the moment.

One more thing I would suggest is to make sure that your router hasn’t got network isolation enabled as that would also prevent devices from seeing one another (or more specifically, it could block direct connections between wired and wireless devices, and I assume that this is a Windows desktop PC here, connected with a cable).

Thank you for your knowledgeable and kind reply, which I have seen only just now.

To my imperfect knowledge, I have Syncthing configured, on the two devices at issue - Windows desktop, Android phone - at default settings. ‘Global discovery’ is enabled on both devices.

Admittedly I did have the ‘listen’ address set, on both devices, to ‘22000’, which I gather now to be a configuration error. (I am considering filing a bug report to the effect that the GUI should complain about such an invalid bit of user entry.) I have set the listen address to default on both devices. I restarted Syncthing on both addresses. And yet, each device continues to perceive the other as ‘disconnected’.

Within my router settings, I have ‘AP isolation’ enabled on for my guest wifi network, which I have not been using (and which has a static IP different to my normal wifi network). I tried disabling that isolation but, predictably, so doing did not help.

I note that I have found the following. In the web UI on the Android phone, I see: unknown address scheme "" (19:45:15) (sic). I do not know how to access the (full) logs on the Android device.

I would appreciate further help!

Here’s the log - with some redactions and set to expire after six months - from the Windows machine.

EDIT: Syncing has began working between the two devices again. Perhaps correcting the ‘listen’ field solved the problem - but took a while so to do . .

The problem of the devices not seeing other has returned. I think that the ‘unknown address scheme’ message means merely that one mode of identifying the device in question has failed). So, my problem persists.

EDIT: Here’s my latest attempted fix. It seems to work (but I said that about the last one!). And it does seem to indicate a bug with Syncthing Android. This attempted solution is inspired by a post on this thread.

Step 1 of the solution: Have a static IP configured in your router for the Android device.

Step 2: Configure Syncthing on Windows.

On Windows, in the Syncthing GUI, go to ‘Remote Devices’, find the Android device, and enter the following within the ‘Addresses’ field. Enter: tcp://<the static IP>:22000,tcp://,tcp://

If there is more than one static IP with which the Android device can end up (because of ‘dual-band wifi’), use a string like this: tcp://<the static IP>:22000,tcp://<another static IP>:22000,tcp://<another static IP>:22000

Seemingly need do nothing on any Linux (proper Linux, not Android) devices, even if they sync with the Android device.


Have you tried, as an experiment, Changing the connection IP address from default to the actual IP address of the other computer?

Not necessarily a permanent solution but it might get your devices talking again.

If you have access to your router you can check the DHCP server settings and see if it will allow you to assign a specific IP address to a specific Mac address. This way your devices even though they’re on Dhcp get the same IP address every time just as though it was statically assigned.

This is what I do and then I put the computer name in the host file.

This only works if your devices are local on the same lan at the same time.

@ er, ‘Wank’

If I understand your suggestion, then I have indeed tried it. In fact, yesterday I edited my previous post so as to give the details of that very procedure. It seeks to work! (Yes, it will work only when I am home, but that is what I want, anyway.)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.