Win 10 and 11 updates breaks --no-console

Innstalled the latest updates for Windows 10 (KB5018410) and 11 (KB5019509) on two separate computers.

I’ve been starting syncthing.exe with --no-console. This switch does no longer work correctly. A console window is launch and minimized, not hidden.

Has anyone experienced the same?

Do you use Windows Terminal by any chance? If yes, have you set is as the default console? In the case of Windows 11, it may already be like that by default. If that is the case, then it is and you will need to switch to the “legacy” console in order for the -no-console flag to work.

If the goal is to start Syncthing automatically on boot, you can also leave the Terminal as default and use the Task Scheduler method from to still be able to run Syncthing invisibly in the background.

1 Like

That seemed to have fixed it.

Another possible wrinkle - I have two PCs that were both Windows 10 previously, but I did in-place upgrades to Windows 11 on both. One of them exhibits the behavior described here - launching a terminal window at startup when Syncthing starts, but the other does not.

The only thing that I can see that is different is that the machine that Syncthing doesn’t spawn a console window is that it is running Windows 11 Pro, while the other (which spawns the console window) is Windows 11 Home.

I was able to fix it on the Windows 11 Home PC by ticking the box in the Syncthing shortcut in my Startup folder to use the legacy one. I didn’t have to do anything with the Pro machine since it “just worked”.

EDIT: They may have been different builds after all.

Win 11 Pro is Version 22H2, Build 22621.674 Win 11 Home is Version 22H2, Build 22621.755

I am updating the Pro machine now to see if the behavior changes and it starts spawning the console window.

UPDATE: Indeed the difference was the builds, not the Pro vs. Home versions. After upgrading from 674 to 755, the console was opening at bootup, so I just fixed that one with the tickbox for legacy mode too…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.