why does syncthing not..sync files?

I have 3 computers and 5 folders set up to sync. 4/5 are 100% up to date 1 folder refuses to sync. there are seemingly random numbers of failed files that never sync.

iv tried deleting and re-syncing, removing and re-adding, deleting the offending files, nothing i try gets the folders in sync. it was originally limited to one of the computers, but now all of them are fked up

the most common things I seem to see are:

“generic error” - unhelpful

“file modified but not rescanned; will try again later” also unhelpful. if the file is modified wth doesn’t it sync it?

“no connected device has the required version of this file” - this makes no sense to me, the required version is the most recent available. why doesn’t it sync it. why is there no “yes, yes, i know, sync anyway because this is irelevant” button?

I’m probably missing something but this has me…irate and I’m not thinking clearly about it. I have tried to use syncthing before and gave up for this same reason; syncthing, a program to sync files, refuses to sync files.

on paper is looks like it does exactly what I want and then it just doesn’t do the most basic thing; sync. the. files.

and, just to reemphasize, 4 folders work with no errors, they just work.

Syncthing does sync files. You’ve agreed to that already.

However, there seems to be something that is stopping one folder. Is it just the one folder? Is this always the one that is causing issues?

Can we please see screenshots of the GUI to help us out?

What kinds of files are you trying to sync? Is there a database, other sync software, backup software, or anything else that might be causing issues? Why do you have 5 folders? Is it because they’re all different, or are they just different locations? If they are different this might lead to us being able to diagnose your particular issue.

World of Warcraft/_retail_/interface/addons (failures)
World of Warcraft/_classic_/interface/addons
World of Warcraft/_classic_/WTF
World of Warcraft/_retail_/WTF
my docs/Elder scrolls online/

it was originally just 2 folders, but the WoW folders spat out constant errors and I split it up, which isolated it to the _retail_ addons being the problem somehow

I don’t see a way to upload any screenshots.

there is no other backup software (I dont use these, things i care about are on freenas and replicated with zfs)

the wow addons are installed with the twitch client, and it has a sync function. it worked fine with classic, but i disabled it anyway. no noticeable change

i run WoW and ESO on these 3 computers (one at a time), and just want the addons and their settings to be the same. there is no real data i care about, I just need them cloned the next best option ive thought of would be custom rsync scripts from my nas…but that wouldnt be seemless, and would only work on my network - syncthing seems like it would solve it but instead almost works and doesnt seem to give me anything I can use to find out why.

it’s more than possible that I messed something up trying to fix the first errors, but I cannot figure out a way to tell it to just update everything and scrap anything that isnt the newest available file. contents don’t really matter in this folder.

Because Syncthing will not shred your data. This message occurs in e.g. this scenario: Device A and B both have version (A:1) of a file. The B modified the file, so it now has (A:1,B:1). A tries to get that file from B, but before overwriting the local file on disk it does a final check that this file hasn’t been modified. And it notices it has been modified. So instead of overwriting, it aborts syncing, scans the file and now has version (A:2). There is now a conflict with device B. If the file content is in fact the same, that will be resolved silently, otherwise a conflict file is created.

This isn’t irrelevant: How can it sync if it isn’t connected to any device that has the file it wants to sync.

The first problem sounds like a file that is constantly updated (which for a game sounds plausible) and the second is due to connection problems (or rapidly changing files on all devices).

I need a “Shred data and sync” button…

i resolved all the conflicts. i still have 882 unsynced files with " file modified but not rescanned; will try again later".

classic/addons and retail/addons function the same. only one of them has any problems

neither. the files are used on one device at a time (impossible to launch more than one instance of the game) and the connection is GB LAN.

again, how can I get it to sync the files. judging by the other folders, it should work fine if I can just get the damn thing in sync. Iv tried deleting offending files to try and get it to just resync, but that doesnt work at all.

iv tried removing the sync folder, deleting 2 of the copies, recopying, recreating the sync folder…and still it will say its out of sync.

I just dont get it

That just proves that it’s working fine, and there’s something special about these directories. I mean you have already narrowed it down to which directories are the culprit. Start checking offending files (mtimes, permissions, …) and comparing them across devices.

Rapid changes on a single device are enough. Do this persist when the game is stopped? Also GB LAN has nothing to do with it, post screenshots if you want to convince me that you have connections. Actually just post screenshots if you want help, because otherwise we are in the dark about your setup/status.

Neither do I and neither can I, as only you have access to your devices and you don’t seem to have much interest in following up with well meaning help.

at the moment I am deleting everything, again, to try and reset everything to one state where I at least know everything is the same version. I did find one folder that seems to have gotten nested too many times, though I am unsure if that is a cause or a symptom (_retail_/interface/addons/addons/addons - should only be one addons subfolder :confused: )

additionally, the addons folders are not changed by the game, they are loaded into memory only. all settings and variables for the game client and addons are stored in the WTF folders. the addons folder is functionally readonly to the game client itself, the only changes are when updating the addons, which requires a complete restart of the client to reload from disk.

sync setup with new folders. b85me and g75vx are directly copies from x99a2, and then the folder sync is setup from x99a2 and shared to the other 2. the files are immediately out of sync. nothing should be open that changes any of these files, and nothing is open that changes these files that would not also change the classic files. I have the full log files but…they are 100mb of errors and counting.

The noticable thing is your global state having almost twice as many files as the local state. Usually I would suspect case only changes, which is a known problem with Syncthing. However I couldn’t spot any in the screenshots. Still, that might be something to check.

When you say you reset everything, what do you do exactly? Do you delete the data on disk and the syncthing folders, restore the data on all the devices and then recreating Syncthing folders? If that gives you problems (shouldn’t obviously), another thing you could try is restoring on just one device and letting Syncthing take care of the other devices.

i deleted the settings from syncthing for retail, deleted retail/interface/addons/* from b85me and g75vx, copied retail retail/interface/addons/* from x99a2 to b85me and g75vx, created the syncthing folder on x99a2, and then shared to the other 2, pointing them to the existing files. the screenshots are of the results of that

what does that mean?

That sounds definitely weird then, no idea what’s going on.

That on one device you have e.g. foo/bar and on the other foo/Bar, which on Windows creates problems as it is case-insensitive.

ah, ok then. that shouldnt be the problem since the folders should have started out identical. but at this point i just don’t know

i’ve tried to use syncthing a few times over the years, and it just does this every time, and I can never figure out why. all I need it to do is clone the files using the most recently modified version, and it’s mind blowing to me that a problem for syncing files just doesnt do so.

I am pretty sure this is an issue with case differences somewhere. I suggest you post a screenshot of one of the failing files visible in explorer on both sides.

OH I SEE IT NOW. so, the answer to my question, “why does syncthing not sync files” is “because case is not Case, even when it is”

looked at the first failure in syncthing, noticed a difference. this difference doesn’t exist in _classic_



I was copying the folders under addons, not addons itself, so, technically, I wasn’t actually making an exact copy, but it never occured to me that that could be a problem until that last post made it click. i assume this is why global state was double local state. they are now equal.

so I just nuked everything, again, deleted a ton of syncthing tmp files in the starting dir, and then copied it all over and rebuilt the sync profile. fully up-to-date now.

does case cause problems with the parent paths, or only within the sync path? will syncthing choke like this for any case mismatch? that’s inconvenient, but I think it explains why I had so many problems every time I tried to used it; checking the case would have never occurred to me since it’s all on windows filesystems.

thanks for putting up with me long enough to get through my thick skull… had to wait 4 hours to reply… :confused: (is there a mark as resolved?)


Only inside the folder synced, not above. It will choke on any case mismatch on a case insensitive filesystem.

it sure would be easier if it could AT LEAST detect the case mismatch as an actual error and just say so, because none of the errors it gave would have lead me to that. at all. I didn’t even know it was case sensitive on case insensitive filesystems (makes sense once I know about it since it does work on case sensitive filesystems as well)