Where is the folder " /volume1/@appdata/syncthing" on my synology?

Hi, I set up sync thing on my Synology DS418 and Android tablet

created a sync folder on Tablet it appears in the web interface and shows the folder on Synology: /volume1/@appdata/syncthing

Where can I find this folder on my Synology?

Pls help THX

If you want to see this folder, you need a SSH connection to your DS system, maybe via PuTTY or WinSCP or similar, since any folder with @ at beginning is a hidden folder and is not visible in the DSM.

Therefore the folder /volume1/@appdata/syncthing is not a working folder for your data. In the DSM you need to give your Syncthing user/group the permissions of your folder you want to share and is visible in the DSM. Maybe you can also set in the web GUI this folder as standard.

Ahh… many THX

Yes, a good idea How to achieve this?

I logged in with Win SCP but cannot see a folder /@appdata ? I have checkt show hiden… image

What is my mistake?

I think you connect with your own account, but you need to connect as root. Best you visit the german Synology Forum to search for Threads, similar to the follow, to have a guide for this:

THX Forum was not very helpful - as always mixed up and messy

What worked for me at DSM 7.0.1-42218 was:

Log in With Putty as admin

sudo -i​

sudo synouser -setpw root PASSWORD​

cd..​

vi /etc/ssh/sshd_config​

remove # from line: PermitRootlogin yes
​
:wq​

reboot​

Start WinSCP​

login as root with new PASSWORD

now I can find the folder: /volume1/@appdata/syncthing

A simple sudo su would have had the same effect without permitting root login if you only wanted a root shell.

Ahh… Would have been a great hint just at the beginning when looking for the folder - THX

As I’m a newbie! Could you pls. be so kind and correct my description to the more easy way? THX in advance

  1. Login as admin
  2. Switch to the root user: sudo su
  3. Access the volume :slight_smile:

THX But I need to log in with Win SCP and I cannot figure out How-To when I use this settings image it does not show all root folders!

Pls be so kind and advise How-To THX

That’s not your shell. You need to enter this command after you logged in.

Edit: not sure if this can be done with WinSCP

Not so easy. Is better to create with PuTTY generator a key, which is stored on the NAS and connect with WinSCP with key, user root and password of root. Thats it.