Where are the repo settings and cache on Android?


I want to edit the actual xml files because ST Android is throwing chmod errors every second, no good for me. The Gui does not show the repo but the web gui does. However the web gui does not let me save the changes therefor I need to figure out where the actual settings are residing.

The repo shows to ignore permissions but the logs do not seem that way. I have millions of these

“I/SyncthingNativeCode(22723): [2JOJA] 03:16:18 INFO: mkdir: error: “xxxxxx” / “xxxxxxxxxxxx.pdf”: chmod /storage/emulated/0/xxxxxxxxxxxx/xxxx/xxx: operation not permitted”

I just want to force it to rescan and recreate its sync status (properly). It keeps recreating the deleted folder with dot versions of the files in it even after I removed them from the other node as well.

I looked into .config/syncthing but that does not have the repo I have not sure if that is from some older versions.

I am on a rooted system using ST And Arm7 0.5 beta


The config is in /data/data/com.nutomic.syncthingandroid/files/config.xml (needs root to access).

And I will see if I can reproduce your errors, haven’t noticed them yet.


Thanks. How about the cache files?

If you mean the index database, it’s in the same directory.

Is it possible to change the folder configuration (i want to add lenientMtimes=true to a folder) without being root?

from a ux point of view, seems like an op a power user should be able to do… without having to jailbreak the whole thing :smiley:

to give you the specifics, i was trying to do this

This is already enabled by default, see https://github.com/syncthing/syncthing-android/commit/a000eda4e4308770de245710251dbdd1cad12a5a

ah thanks. It was not working for me because the machine I was syncing from was a 0.9.18. Upgrading that seemed to have solved the issue.

What is interesting is that when I run ST binary as root it creates the config files under /storage/emulated/0/.config which is weird because this is where normally it should have created in the first place. When I run the app as a noirmal user all the data is created under /data/data/com.nutomic which can only be accessed by root.

Does not that sound wrong?

Not really, becauuse currently the it is stored in the app’s private data folder, where it belongs.

If you run it through bash, you don’t override the config dir (which the app does), so it ends up in the default location, ~/.config.