Weird folder sync eror


I have Syncthing installed as Docker on OMV5 on my Raspberry pi4.

I have a weird problem going on between my pi and my PC. I have a folder on my Drive F:\ on my windows Computer and want to syncronize it with the same folder on my Raspberry pi with OMV. I connect both together etc. every thing is fine. Then when the scan starts and the folders want to sync, the Folder “Bilder” (picture in german) on my PC inside the folder i am syncing gets recognized as a new folder and syncthing copies the full folder again on my PI in a folder now called “picture” and the already existing folder is ignored. The same also happens with another folder.

Even if i rename them syncthing always does the same, doesn’t matter what i do and how many times i repeat the process and reinstall Syncthing on both devices, it will always do the same.

Can someone help me or explain me why that happens? I really need help.

kind regards Robin

Did you create the directory “Bilder”, or is it the default Windows directory for pictures, which the Explorer fakes the Name “Bilder” for, but is really named “Pictures” inside the file system?

It originally was the home “Bilder” Folder from windows but i renamed it as “My pictures”. So yes it could be that the explorer fakes the name but the moment i rename it it should become a new stand alone Folder or not? Or does syncthing changes the folder name?

anyone there?

The folder IDs need to match, the name or location of the folder is completely irrelevant.

Okey, After many tries it worked. I don’t know why because i just kept creating new folders and moved the data to the new one and after the 5. try it worked finally.

But there is a new problem. Why only some files out of my folder have this error?

chmod /file… :operation not permitted

Fix permissions, the files are owned by a user different than the one running syncthing.

1 Like

@AudriusButkevicius thx

i think it solves it.

Thank you for helping me :slight_smile:

How to close the topic?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.