Web ui not loading and not updating


I was setting up syncthing on a new computer, when I noticed all the other’s gui were at first not loading at all, and after a restart of the services, only showing ‘unknown’ on all folders (although they were mostly synced already when i last checked on them), as well as not reloading at all if I tried to refresh the page (altough it do load again if i open a new tab and open the ui there). I tried clearing my cookies and cache, as well as restarting services.

What you expected to happen: Web gui showing the status of syncing.

Steps done:

  • Setup syncthing on 3 computers for a large data set (> 1.5 TB)
  • Let it sync for one night
  • Notice all the now non-fonctional uis in the morning (while all the services are still running).

These screenshot were taken after restarting the services (after all the uis stopped loading) on the morning. Uptime isn’t updating either. All folder show 0 items, 0 bytes.

h tt ps://cloud. githubusercontent. com/assets/3176238/19383553/4043346e-9205-11e6-8f5e-18dcee8aed67.png edited for use h tt ps://cloud. githubusercontent. com/assets/3176238/19383554/40447cb6-9205-11e6-9768-fd479290f4bc.png

Version Information

Syncthing Version: v0.14.8 OS Version: Windows server 2008 r2 / Centos 6.8 Browser Version: Chromium 53.0.2785.143 (64-bit)

Check Js console for errors

I don’t see any red.

Do you see any outstandig http requests?

Yes, everytime i try to refresh I get those pending requests:

And this is for a new tab:

I currently have a device in the same state, let’s see if the deadlock detector will kill it in 1 hour (set it to this after seeing the same thing yesterday). Could this be #3634? The description here sounds similar.

It looks like disabling relaying solved the problem, thanks.

Yeah enable tge deadlock detector and post traces on the same issue.

That log was too long it was already partly deleted by rotating the logs :confused: let’s see if it happens again to get a full trace.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.