Web interface login (credentials)

Hi! I just started using syncthing for a few week and all of a sudden, I’m asked for credentials when I try to open the web interface on my Mac (M1, Brave Browser). I tried syncthing / [API Key] as I read somewhere, but this does not work.


  • What are the default credentials?
  • If I had set them and don’t remember, how can I reset them?

Thank you very much for your help!


The default is no credentials. See this FAQ for how to reset them: https://docs.syncthing.net/users/faq.html#how-do-i-reset-the-gui-password

Thank you very much for your answer André! =) So how did I log in to the web interface without credentials before?

But more important, the FAQ says:

syncthing generate --gui-password=myNewPassword --gui-user=newUserName

But where do I enter that? If I put it in the terminal, it only says “zsh: command not found: syncthing”

What am I doing wrong here?

I suppose that depends a little on how you installed Syncthing. If you used the Application Bundle for MacOS then you first have to dive into the Application Bundle;

cd /Applications/Syncthing.app/Contents/Resources/syncthing

There you can run

./syncthing generate --gui-password=… --gui-user=…

(obv the above two steps can be combined)

Or if you rather just modify config.xml yourself using some text editor, this should be - per default - available as;

~/Library/Application\ Support/Syncthing/config.xml

There you can just remove the user and password tags within the gui part.

1 Like

Thank you very much! With viewing the config file, I remembered the login I gave it initially.

Thanks for the help - solved my problem! =)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.