Web interface connection error (forbidden?)

Hmmm I just freshly reinstalled my laptop (kubuntu 15.04) and freshly reinitialised syncthing, but I get very often the message that syncthing might be down (see screenshot)…Refreshing the page does work OK (Firefox). Trying to debug it with STTRACE=all syncthing doesn’t show anything added in the log when it happens. It happens when adding a device or changing anything actually (listening port, deleting default folder, etc)…I am probably doing something wrong for debugging? Weirdly enough in a virtual machine it worked fine .

Check the javascript console log. This is usually due to some sort of proxy being involved between you and syncthing.

Even when I am not using a proxy at all? Definitely not for…

I apparently get a forbidden???

Are you using some special extension which kills cookies or something?

Nope…freshly installed laptop …with the rekonq webbrowser I get the same :frowning:

Well it’s either not providing the CSRF cookie, or not providing session cookie/authentication credentials. Nothing todo with 0.10 vs 0.11 as far as I know.

Your browser has a warning saying it’s not going to send the password, so I guess that’s your issue.

Could be, but now I also tried version 0.10 and all works fine then…

Can you start a separate thread and provide the actual request content sent by the browser. Potentially both requests to the same URL, one sent to 0.10 one sent to 0.11

I could. but it seems to have solved itself…tried chromium browser, which worked OK, so I decided to remove my whole firefox profile stuff (under linux the whole .mozilla directory) and now it seems to work fine with firefox too…It breaks my wooden shoe as we say in the Netherlands, but it might have to do then with the kubuntu 15.04 version maybe…don’t know…If it happens again I’ll open a new thread and bug report…Thanks for the assistance :smile:

You are viewing two webguis at the same time (walhalla and hoefnix). This does not work, see the FAQ.

Hmmm good point Zillode…thanks for pointing it out…