Web interface access on Ubuntu


I am new here, posting a first question which hopefully makes sense and won’t end up in “read the …”. I searched but could not find an answer or related question.

I am running Syncthing ver 1.0.1 on Ubuntu 18.04 (and an Android mobile phone) successfully as it looks like. A single folder at this stage is synchronised nicely between the devices.

The Ubuntu icon in the top bar shows an exclamation mark beside the icon and when clicking the icon, I can select underneath to change the status from currently “Syncthing On” to “Off”. Below that entry is the grey line for “Web interface” which means I cannot click/follow that to get access to the GUI. However, I can get access to the Web GUI by manually using “” in the browser so the GUI is actually working, just not the menu item.

BTW, I am sure that was working at some stage in the past (earlier Syncthing version maybe?) but cannot remember when it changed.

Thanks for any hint, Michael

Do you use syncthing-gtk?

Thank you for your follow up. Sorry if it sounds a little stupid but I do not know. I have installed the Ubuntu binary package at some stage.

I however have finally realised to look into Ubuntu’s syslog and find the below which looks to be (core?) part of the problem:

Feb 12 11:57:44 x gnome-shell[1493]: [syncthingicon] Failed to read config file /home/xxx/.config/syncthing/config.xml: undefined:1:1: text data outside of root node. Feb 12 11:58:13 x gnome-shell[1493]: [syncthingicon] Failed to connect to syncthing daemon at URI “http://localhost:8384”: Forbidden Feb 12 11:58:13 x gnome-shell[1493]: [syncthingicon] CSRF Error. Please verify your API key.

Ok, so you are probable using the Gnome desktop environment and have https://github.com/jaystrictor/gnome-shell-extension-syncthing installed. If there is some sort of config/settings for that (e.g. check this icon), search for an an API key and compare it to what you find in the web UI under Actions->Settings. If that doesn’t help, I’d ask the creator of this app (see link above).

I have Syncthing installed from the Debian repositories, and syncthing-icon through extensions.gnome.org. I enabled the systemd unit, and everything just worked. syncthing-icon is set for automatic configuration - the settings dialog is accessible through gnome-tweaks and the extensions website.

Thanks for the pointer. I now understand that I have “syncthing-icon” installed as a Gnome shell extension and have reported the issue there. Trying to tweak (change its settings) or uninstall/reinstall for that does not solve the issue so let’s hope I will get some help to find the source of the problem. I will come back here to report back. Thanks for all that tried to help so far.

Just wanted to report that it was an issue with “syncthing-icon” only which has been resolved in an updated version. No issues with syncthing itself . Thanks for reading and replies.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.