Warning "remote expects to exchange plain data, but local data is encrypted"

I get this warning when sharing a folder with encryption key to an untrusted device.

“[…] remote expects to exchange plain data, but local data is encrypted”

In the documentation it says: “On untrusted devices, you need to set the folder type to “Receive Encrypted”"

But I saw no such option when adding the folder on the untrusted host anywhere.

Can anybody help me?

It’s on the advanced tab when you create/add the folder.

1 Like

I don’t have this option tho:

I can’t change the language but it only gives the option listed here: https://docs.syncthing.net/users/foldertypes.html

Which version of Syncthing is it? If there is no Receive Encrypted folder type available, it’s likely something heavily outdated…

1 Like

“Untrusted” Client: syncthing v1.12.1-ds1 “Fermium Flea” (go1.15.9 linux-arm64) debian@debian 2021-07-23 20:27:51 UTC

Sending Client (trusted):

syncthing v1.23.0 “Fermium Flea” (go1.19.4 darwin-amd64) brew@Ventura 2023-01-02 03:45:30 UTC [noupgrade]

So I guess the untrusted client is outdated. But I followed the exact instructions from https://apt.syncthing.net. Therefore using apt update && apt upgrade syncthing doesn’t do anything:

sudo apt upgrade syncthing

Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

syncthing is already the newest version (1.12.1~ds1-4).

Further down on the same installation webpage is a section about setting the priority. Without doing that, the version in the default repo for your Debian or other Debian-based Linux distribution takes precedence (i.e., you have two version of Syncthing available when using the command apt install syncthing)

Use the following command to see details about the default package:

apt-cache show syncthing
1 Like

Oh oups I skipped that section in my head. But now how do I upgrade my existing installation? I typed the command given in the documentation, but it still doesn’t let me upgrade anything.

apt-cache show syncthing

still shows the old version…

Nevermind I fixed it. Had to manually add **echo "deb [signed-by=/usr/share/keyrings/syncthing-archive-keyring.gpg] https://apt.syncthing.net/ syncthing stable" | sudo tee /etc/apt/sources.list.d/syncthing.list* again for some reason, but now it updated successfully. Thanks for all your help! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.