v.42 won't connect to/from a Windows box. v.41 is okay.


(Brian) #1

I have a Mac and two Windows machines, as peers behind a router modem. An older Windows machine has begun to always stay in the “Disconnected” state (the other works fine). v.42 on both window machines. Downgrading to v.41 on the older machine fixed the problem. Something doesn’t work right in v.42 about connecting.

I thought it might be a firewall issue on the isolated machine because the syncthing log never says Established Connection. It reports can’t fetch release info from upgrades.syncthing.net and it can’t post a usage report to data.syncthing.net, reporting “no such host”. When I turn off the firewall, nothing changes. All machines have “dynamic” as the method of finding others.

The working windows machines shows the other at the proper IP (kcp://10.0.0.104:22020 tcp://10.0.0.104:22000). On the isolated machine it just says “dynamic”.


(Audrius Butkevicius) #2

This is still a firewall issue. Windows is famous for not caring about firewall enablement status when it thinks your binary is suspicious and keeps sandboxing it anyway. I suggest you explicitly add it to the exception list on the disabled firewall, and check that file properties for the binary do not have a checkbox saying “I trust this file even if it was downloaded off the internet” or something like that.


(Audrius Butkevicius) #3

Also, check that you actually have internet connection not through a proxy on that machine.


(Brian) #4

Audrius,

I would agree it certainly ~sounds~ like a firewall issue. The computer having comm trouble is behind a home modem/router, trying to talk to other peers behind the same router. I don’t have a proxy. Just a few computers NAT’ed behind the modem/router.

On the box itself, with Zonealarm firewall off (I don’t use the Windows firewall), I don’t know how to make the firewall do any less than turning the whole firewall off. The issue was fixed by using v.41, so if you are correct, it seems to be a firewall issue only with the newer v.42 version. I’ll test the whole thing again when the next version comes out.

However, matching your suggestion, I had already manually deleted all entries for syncthing and re-allowed syncthing to do any inbound and outbound comm it desired. That didn’t work, which is why I just turned off the entire firewall.

(BTW, remembering to our other conversation about staying always up to date with the newest and the best… I’ll point out, that this problem started only when I did allow an upgrade. Experiences like this are one reason I have a bias toward older stable software and architectures.)


(uok) #5

@increa, you can download older versions from https://github.com/syncthing/syncthing/releases to help with finding the bug. Please ping upgrades.syncthing.net and data.syncthing.net to eliminate DNS and firewall errors. You can also try to enter static IPs for each device and see if this helps with connection.


(Audrius Butkevicius) #6

It’s definately not a bug introduced in recent version, as there hasn’t been anything related to connections in general, and everything is failing.

I am 99% sure windows finds the binary suspicious and sandboxes it using windows firewall (even if its disabled). OP should check file properties as I suggested and add the binary to exceptions in Windows firewall.


(Brian) #8

Uok, Dho,

Using other programs, I can ping the servers. In fact, I tried to access the data collecting server from a web browser. The affected computer connected without a problem although the host immediately replied that my data was in the wrong format (of course, since I didn’t really send any data).

Something about the syncthing program, per se, was being cut off from other computers inside my router and prevented from accessing the larger internet. It seems it’s the environment of my computer – except that the older version of syncthing worked/s fine. When the next version of syncthing comes out, I’ll try swapping them back and forth and see if I can gain any meaningful information.

Yes, I added the binary to the exception list. I did that before trying to shut off the firewall entirely. I think Audrius is saying the firewall does block things even when disabled.


(system) #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.