Use URL instead of IP

Is it possible to use an URL rather than an IP address to setup the sync ? I would like to sync Windows computers on my NAS, but my IP is not fixed…

A URL consists of several components, looking similar to what you configure as device addresses. But what you mean is probably just the host or domain name. If it resolves to the correct IP address, yes you can use it two configure remote device addresses.

Thanks, it sort of worked. I was having a strange error message when trying that yesterday.

Now I don’t have this message anymore. But I face another issue…

When I type my host name here, I see that it leads to the right IP. But I systematically have a « connection refused by the host » error. When I set it to dynamic, it connects…

When it does connect, can you check the connection type in the remote device details? It’s in a tooltip window when hovering over the address.

Also, posting detailed error messages might help.

In fact, discovery does not change anything, I have the exact same behavior if it is enabled or disabled

If set the address to “tcp://myhostname:22000” or “tcp://XXX:XXX:XXX:XXX:2200”, I see that my IP address is correctly retrieved, but I have a message “No connection could be made because the target machine actively refused it”. Now, I don’t see this message anymore, but only “i/o timeout”

If I set the address to dynamic, they do connect and I see the following if I hover over the address It says “quic-client TLS1.3-TLS_CHACHA20_POLY1305_SHA256”

I precise that the only change I make is changing the address from “tcp://myhostname:22000” (or tcp://XXX.XXX.XXX.XXX:22000) to “dynamic”. No change in my ports forwarding in my router or anything else. I only change the address in synchthing on my laptop.

I add some precision… The machine I am trying to sync with is in a container on my NAS. Port 22000 is forwarded for both TCP/UDP from my ISP router to my main router and from my main router to my NAS.

Because Windows is involved, please make sure that your network in the OS is set to “private” and not “public”, as otherwise Windows will not accept any direct connections. Please check if you need instructions on how to do it. The article says “Wi-Fi”, but the situation is exactly the same with wired networks.

Thanks ! I would not have thought about that. Unfortunately, I am not going to be able to test that now… The laptop I am using for my test is my professional laptop and I cannot change this setting (but it is set on public…) As soon as I have the actual computer I want to sync at hand, I’ll try again.

Nope… Did not change anything… If I directly type the IP or the host name, it does not connect with an I/O Timeout. If I set it to dynamic, it works…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.