Update of Syncthing on NAS Zyxel NSA325-V2

I haven’t found any description for updating Syncthing on NAS Zyxel NSA325-V2 and here I summarize how to do it for the linux-amateur folks like me.

Syncthing is available on Zyxel NSA325-V2 through the MetaRepository package of Mijzelf. http://zyxel.diskstation.eu/Users/Mijzelf/zypkg-repo/README.html This contains a lot of important stuff and an old version of Syncthing, v.0.12. Update from the web interface doesn’t work. As I read somewhere you cannot update from 0.12 to 1.4 directly. You have to manually update 0.12 to 0.13 first and then you can use the web interface update to v 1.4.

Syncthing folders Place of the executable file, “syncthing” : /usr/local/zy-pkgs/bin Place of config files: /md0/admin/Pulse If you backup the config files and you copy them back to here after a reinstall of your NAS you can keep all your configs.

Update steps

  1. It’s useful to install midnight commander that is the part of the MetaRepository package. This is a file manager like total commander in windows. You can easily do that on webinterface: System Setting - Firmware/Packages
  2. Download of Syncthing V0.13.10 arm version, from here: https://github.com/syncthing/syncthing/releases/download/v0.13.10/syncthing-linux-arm-v0.13.10.tar.gz
  3. Stop Syncthing
  4. After extracting the compressed file (you can do that with mc as well) copy the file “syncthing” into the folder /usr/local/zy-pkgs/bin (you overwrite the old syncthing executable here)
  5. Restart Syncthing
  6. To get the automatic update working make temporarly the folder /usr/local/zy-pkgs/bin writable. For non-linux users: it’s easy to make that in midnight commander file menu/ChMod command.
  7. Run update from web interface of Syncthing to get the update to v 1.4.

Have you tried poking them to upgrade the Syncthing package to something less ancient?

Hello, I tried to follow you advise. Unfortunately, I do not have the /usr/local/zy-pkgs folder. Instead the old module “Pulse” is working for me, I want to upgrade to v1.4. Can you please tell me where I can find that syncthing/pulse file? I have a Zyxel NAS542.

bye Chefkoch

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.