Update Loop / Out of Sync with Reality [SOLVED; works now]

UPDATE: works now (this thread can be closed; sry for the spam ^^")

In the GUI of my notebook (“coyote windows”) the entry for the other device (“raspberry”) occasionally flashes, but then returns to “Disconnected”. I looked at the logs linked below and tried googling for the error messages, but couldn’t find anything that seems to explain or help with the issue short of doing a code-base dive. I’ve also restarted and updated everything as far as possible (the docker image has no newer version than 0.14.36), restarted the devices and the router. I don’t know if it’s an issue with the docker setup, so I created an issue there as well and this thread in case it’s something already known (sry for the spamming, need to get this working again soon ^^")

The full logs from the raspberry (including config and command used to start it) using funkyfuture/docker-rpi-syncthing (just updated; 0.14.36), and the log from windows notebook using the regular desktop install (0.14.38) are linked there as well (as i can only have one link per post here). Both devices are connected to the same router via lan-cable.

In stdout (docker logs) on the raspberry the following lines repeat:

[GA5EM] 21:08:52 INFO: Connection to OLIDSIJ-...-5D3M4QM closed: reading length: read tcp> use of closed network connection
[GA5EM] 21:09:49 INFO: Established secure connection to OLIDSIJ-...-5D3M4QM at (relay-client) (TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305)
[GA5EM] 21:09:49 INFO: Connected to device OLIDSIJ-...-5D3M4QM with a newer version (current "v0.14.36" < remote "v0.14.38"). Checking for upgrades.
[GA5EM] 21:09:49 INFO: Device OLIDSIJ-...-5D3M4QM client is "syncthing v0.14.38" named "coyote-windows"
[GA5EM] 21:09:49 INFO: Sharing folder "MiscPrivate" (k99ed-j6tnh) with AMX4UUE-...-3BHJCAG (vouched for by introducer OLIDSIJ-...-5D3M4QM)
[GA5EM] 21:09:49 INFO: Automatic upgrade (current "v0.14.36" < latest "v0.14.38")
[GA5EM] 21:09:50 WARNING: Automatic upgrade: open /usr/bin/syncthing779817328: permission denied


on the notebook it’s:

[OLIDS] 22:36:35 INFO: Established secure connection to GA5EME4-...-LUQKSAV at (relay-server) (TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305)
[OLIDS] 22:36:35 INFO: Device GA5EME4-...-LUQKSAV client is "syncthing v0.14.36" named "dba8ed63b117"
[OLIDS] 22:36:35 INFO: Device GA5EME4-...-LUQKSAV folder "K" (k) is delta index compatible, but seems out of sync with reality
[OLIDS] 22:36:35 INFO: Unsharing folder "MiscPrivate" (k99ed-j6tnh) with AMX4UUE-...-3BHJCAG as introducer GA5EME4-...-LUQKSAV no longer shares the folder with that device
[OLIDS] 22:36:36 INFO: Restarted folder "MiscPrivate" (k99ed-j6tnh) (readwrite)
[OLIDS] 22:36:36 INFO: Connection to GA5EME4-...-LUQKSAV closed: writing message: tls: use of closed connection
[OLIDS] 22:36:41 INFO: Completed initial scan of readwrite folder "MiscPrivate" (k99ed-j6tnh)
[OLIDS] 22:45:57 INFO: Disconnected from relay relay://

Nevermind, after I spend half an hour documenting this, they decided to connect to each other again ^^

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.