Unknown device


#1

I just installed syncthing on 2 computers. On one it works perfect, but the other one the GUI shows “unknown device”. In the logfile he he sees the computername but not in the GUI. He shows also http://localhost:8384/# ! I hope you can give me a hint?


(Audrius Butkevicius) #2

Please provide the full log


#3
2019-01-17 10:50:53 syncthing v1.0.0 "Erbium Earthworm" (go1.11.4 windows-386) teamcity@build.syncthing.net 2018-12-26 16:23:05 UTC

2019-01-17 10:50:53 My ID: H6FWBTH-RFKGJXQ-WV5MZQY-N7J2VO2-5FHHMKH-SSCQDN7-32UR6KI-4BUEUQ7

2019-01-17 10:50:54 Single thread SHA256 performance is 77 MB/s using crypto/sha256 (44 MB/s using minio/sha256-simd).

2019-01-17 10:50:54 Hashing performance is 53.47 MB/s

2019-01-17 10:50:54 Ready to synchronize "Default Folder" (default) (sendreceive)

2019-01-17 10:50:54 Overall send rate is unlimited, receive rate is unlimited

2019-01-17 10:50:54 Using discovery server https://discovery-v4.syncthing.net/v2/?nolookup&id=LYXKCHX-VI3NYZR-ALCJBHF-WMZYSPK-QG6QJA3-MPFYMSO-U56GTUK-NA2MIAW

2019-01-17 10:50:54 Using discovery server https://discovery-v6.syncthing.net/v2/?nolookup&id=LYXKCHX-VI3NYZR-ALCJBHF-WMZYSPK-QG6QJA3-MPFYMSO-U56GTUK-NA2MIAW

2019-01-17 10:50:54 Using discovery server https://discovery.syncthing.net/v2/?noannounce&id=LYXKCHX-VI3NYZR-ALCJBHF-WMZYSPK-QG6QJA3-MPFYMSO-U56GTUK-NA2MIAW

2019-01-17 10:50:54 TCP listener ([::]:22000) starting

2019-01-17 10:50:54 ...

2019-01-17 10:50:54 My name is "DAPA73408"

2019-01-17 10:50:54 Relay listener (dynamic+https://relays.syncthing.net/endpoint) starting

2019-01-17 10:50:54 GUI and API listening on 127.0.0.1:8384

2019-01-17 10:50:54 Access the GUI via the following URL: http://127.0.0.1:8384/

2019-01-17 10:50:54 Completed initial scan of sendreceive folder "Default Folder" (default)

2019-01-17 10:50:57 Relay listener (dynamic+https://relays.syncthing.net/endpoint) shutting down

2019-01-17 10:50:57 Couldn't fetch release information: Get https://upgrades.syncthing.net/meta.json: dial tcp: lookup upgrades.syncthing.net: no such host

2019-01-17 10:50:57 Automatic upgrade: no version to select

2019-01-17 10:50:57 Relay listener (dynamic+https://relays.syncthing.net/endpoint) starting

2019-01-17 10:50:57 c.S.listenerSupervisor: Failed service 'dynamic+https://relays.syncthing.net/endpoint' (1.000000 failures of 2.000000), restarting: true, error: "{dynamic+https://relays.syncthing.net/endpoint dynamic+https://relays.syncthing.net/endpoint} returned unexpectedly", stacktrace: [unknown stack trace]

2019-01-17 10:50:57 Relay listener (dynamic+https://relays.syncthing.net/endpoint) shutting down

2019-01-17 10:50:57 c.S.listenerSupervisor: Failed service 'dynamic+https://relays.syncthing.net/endpoint' (1.994089 failures of 2.000000), restarting: true, error: "{dynamic+https://relays.syncthing.net/endpoint dynamic+https://relays.syncthing.net/endpoint} returned unexpectedly", stacktrace: [unknown stack trace]

2019-01-17 10:50:57 Relay listener (dynamic+https://relays.syncthing.net/endpoint) starting

2019-01-17 10:50:57 Relay listener (dynamic+https://relays.syncthing.net/endpoint) shutting down

2019-01-17 10:50:57 Entering the backoff state.

2019-01-17 10:50:57 c.S.listenerSupervisor: Failed service 'dynamic+https://relays.syncthing.net/endpoint' (2.990360 failures of 2.000000), restarting: false, error: "{dynamic+https://relays.syncthing.net/endpoint dynamic+https://relays.syncthing.net/endpoint} returned unexpectedly", stacktrace: [unknown stack trace]

2019-01-17 10:51:05 Detected 0 NAT services

(Audrius Butkevicius) #4

Suggest you check web browser console for errors that lead to that state in web ui. I suspect you have a firewall causing this.