"Unknown-dev" Docker on Raspberry


I installed syncthing on my raspberry, but the ARM image doesn’t exist. It’s not a problem, because, with the dockerfile available on github, I built my syncthing docker, but the version don’t display it on my homepage. But, when I want to sync with devices, my local syncthing tell me the “destination” syncthing doesn’t have a good version to work well.

I tried to add a tag in my docker when I built it, but it’s the same.

Do you know if it’s possible to force the version number or how is it possible to add in synchting ?

Thank you !

To get a proper version tag you need to build from a fit checkout that has version tags, or from a release tarballs that had the release file in it. Regardless it’s not a big deal if it’s for personal consumption, both sides work even without version tags.

Hi…Just got my rpi4 yesterday and tried to do the same thing and had the same problem. Is it just a matter of waiting for a release to come out or is there an alternative solution?

You’re building yourself, so not clear to me what you would be waiting for. You can check out a release tag in the repository and build the docker image.

% git checkout v1.3.2
% docker build -t mysyncthing .
% docker run -it --rm mysyncthing --version
syncthing v1.3.2 "Fermium Flea" (go1.13.5 linux-amd64) docker@syncthing.net 2019-11-24 08:33:58 UTC

Hi. This also happens if I try to build syncthing 1.3.2 myself in NetBSD 8.0 on RaspberryPi 2.

It seems build.go getVersion() function tries to:

  1. see if it can read version information from RELEASE
  2. fetch the git tag using git

So it fails to get the correct version if, like me, someone downloaded the tag from github.

It seems the website don’t provide official source code tarballs with the RELEASE file? If someone wishes to compile syncthing herself, it she supposed to always git clone the specific tag?

The official source tarball is among the downloads on GitHub; that it’s not linked from the main website is a mistake on my part, I’ll fix it.

Now it’s linked from https://syncthing.net/downloads/


It’s work well for me with this tip on my docker platform.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.