Unable to Sync WhatsApp Folder from Android to Windows

I can’t sync WhatsApp folder from Android to Windows. I saw 0/0 files, 0/0 B, I tried to click on rescan on both Windows and Android.


Windows Android
Windows 10 Android 11




It says “reduced by ignore patterns”. Have you set any? What are the current ignore pattern settings? Check on both sides, especially Android.

Otherwise, it is likely a permission problem.

1 Like


I removed the folder from Syncthing and add it back but without sharing and modify any settings.

I’m waiting for Syncthing to finish scanning first before I modify settings or add devices.

Is better to use your folder and in addition the subfolder …/Media/ and maybe some ignore pattern are needed, but normaly that runs.

1 Like

It’s been a few days and the scan isn’t finished

Does WhatsApp have a backup feature built in? I think it may. A backup directory will contain a copyable version of the database.

I use Syncthing in a similar fashion to back up my Signal database on my phone. Signal backs up the database to a separate backup directory that Syncthing can read properly. You should try doing the same with WhatsApp.

Just checked. My Whatsapp backs up to both Google drive and locally.

The WhatsApp local backup folder is located here: Internal Storage/Android/media/com.whatsapp/whatsapp/backup

Is this backup folder the one you are trying to sync. If not, it likely needs to be.

1 Like

This is the directory I’m trying to sync

I will attempt to replicate by setting up my Whatsapp backup dir to sync to my PC and see if it works.

If you backup to Google Drive, you shouldn’t need to do this also.

Do you have Google backup enabled in the Chat section in Settings? This is what creates the new local backup folder files.

I have already enabled the backup directly from WhatsApp to Google Drive.

I would like to synchronize my WhatsApp files (documents, images, etc.) to Windows with the ignore delete option enabled on both devices. This way, when I delete files on my phone, they won’t be deleted on Windows.

Mine just completed successfully! Synced from my phone to my tablet.

I’m ONLY selecting the “backup” folder, not all of the whatsapp directories. See picture. Try baby steps. Start with just this one folder and then try expanding.

Try that and see if it works for you too.

Perhaps you can’t do the entire whatsapp folder structure.

I just successfully backed up the entire whatsapp folder. One above the “Backup” folder.

There must be something not right on your phone.

See pic.

Still doesn’t work

send and receive

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.