Unable to Sync Over Internet

Good day. Running syncthing on Ubuntu 18.04. I have tried syncing over internet unsuccessfully. The devices just dont find each other.

Followed the docs and tried the following:

  • Forwarding port 22000 on my home router.
  • Using a public relay.
    Neither work. Any advise is appreciated. Thank you.

Logs, screenshots, etc.

Screenshot from 2L3PH6F?

You appear to have disabled everything except a relay listener, and it can’t connect to that relay. Don’t do that.

Jakob Thank you. Can you please advise what should be enabled. I didn’t specifically disabled anything.

It looks like you, or someone, has entered relay:// in the sync listen address field. Set that to default.

Thank you. I did that. I thought I was supposed to do that according to the docs.

So both devices set to the relay.

I understand not? Only the “external” pc should be on relay?

I don’t know what you’re trying to do or what docs you’re following. I recommend to start with the basics and the defaults.

thank you. I tried establishing a standard connection over the internet and it didnt work. What I did was forward port 22000 to the pc in my network. It never connected.

I then tried to connect using the relay documentation https://docs.syncthing.net/users/relaying.html#relaying

I picked a public relay and added it to the sync protocal listen address. I added the relay info to both units Im trying to connect. That dindt work either.

That relay documentation is pretty misleading: Synthing will automatically use relays out of the box. I’ll try and find time tomorrow to clarify it, unless someone beats me to it.

The default settings should just work. I suggest you start over from zero and see of you have issues.

thank you. I reset it all and it’s now working. I dont understand why, as I didnt do anything different. But it works

Thank you all for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.