Unable to connect - wrong IP seen

Weird issue im facing with syncthing Client 1 - Ubuntu machine. No docker. Bare bones install Client 2 - Synology NAS running Syncthing as a docker.

When I configure Client 1 to point to Client2 and specify the IP address of the NAS (192.168.3.3) it doesn’t connect.

Checking the logs of Client 1

2024-07-31 10:12:54 Failed to exchange Hello messages with GTOI7NT-CZ7ULI3-VYOPEKC-HHOSLON-DH3UXAU-TUVKCBL-IRKBAHP-UMDDCQ2 at 192.168.69.200:22000-192.168.3.3:22000/tcp-client/TLS1.3-TLS_AES_128_GCM_SHA256/WAN-P30-2VJL3AJ5P5VCO5ULR1PFOSA3EO: EOF

Checking the logs of Client 2

2024-07-31 10:12:54 Connection from JNOSKY2-JLU6Q5T-6P2Q7NI-7G22GDF-WZKBURQ-TLKNMCX-O25DYVD-V2J7MQW at 172.17.0.1:44452 (tcp-server) rejected: device is ignored

No clue why the NAS is seeing 172.17.0.1 address. What is very weird is i have Client 3 pointing to Client 2 (Synology NAS) and that works without issue.

The IP addresses don’t seem to be the problem here, but this:

You need to un-ignore the device on client 2 (Actions → Settings → Ignored Devices → Remove) if you want them to connect now (at some point in the past you told syncthing to ignore that other device, so they can’t connect now).

wow… Im hunting down why synology is treating this connectivity differently and you gave a very simple fix that works.

bravo.

Thank you !!