Unable to connect to Web UI on Synology

Trying to set up Syncthing on Synology (Following instructions from How to Install Syncthing on Your Synology NAS – Marius Hosting). I am not able to get to the Web UI. I also have installed Syncthing on both of my Ubuntu machines. I had problems there too until I figured out to set the GUI address in config.xml to “”. Now I can get to the Web UIs for both Earth and Mars (the names of my Ubuntu machines). Made the same edit on the Synology for Syncthing in the config.xml but I can’t get to that web UI either by name (Jupiter (also in /etc/hosts)) nor by IP address.

Of note, I’m running Syncthing on Synology in a docker container and yes I have verified that config.xml inside of the docker container contains a GUI address of “”. No firewalls involved.

I have no idea where the log file is for Syncthing within a docker container. I tried docker logs but nothing gets written there.

On a side note, I’d like to use https but I keep getting prompted about a self-signed cert. Is there a way to get rid of that warning?

You changed the config but did you also configure the port mapping of your container accordingly? The container might still be bound to

You should be able to ignore the warning once in your browser and it should remember this decision.

The other options would require either a reverse proxy setup with LetsEncrypt certificates or running a custom CA.

Don’t know what you mean by “configure the port mapping of your container”. THe ports are already mapped (8384, 21027 and 22000). Ah… In the Synology interface I had left the “Local port” field blank. That’s the default and I assumed that the default would equal the specified port (IOW 8384:8384, etc.). Specifying the actual ports has gotten this to work! Thanks.

As for the reverse proxy/LetsEncrypt stuff, I’ve already set that up for a number of other docker container/services I run so I’ll just add this one to the mix.

Once again thanks (now to figure out how I want to use Syncthing and what I want to sync…)

Make sure to enable authentication and use a strong password if you make your web ui accessible from the internet.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.