UI browser connection refused, ip/port missing

I’m hoping this is a simple solution as it used to work but now suddenly doesn’t. I have the Syncthing UI set to the default ip/port of This is confirmed in the runtime output: “Access the GUI via the following URL:

When I launch Syncthing.exe, it automatically opens a tab to that address but fails to connect due to the connection being refused. This is on Windows 11.

I ran netstat -aon to list all ports in use. There is one at [static ip]:8384 which I can hit, though it says “Host check error”. There is not one at

Not sure how one “registers” an ip/port but that seems to be the issue. How do I go about fixing this?

Immediatly above that line in the log output, there should be a line that says something like this:

GUI and API listening on

What does your log say?

It says: “GUI and API listening on” (my static IP)

That means syncthing is configured to listen on that address and hence is only reachable there. Thus, this

is not the case. If you want syncthing to be reachable on, you must configure that address in the listen address.

This is a guess made by syncthing, based on available network information. It may not be correct in all setups. The above line we discussed is the actual listen address.

(Though, the “host check error”* means that syncthing thinks it’s listening on localhost, while it actually isn’t. This indicates that some network weirdness is going on. Perhaps your syncthing is configured to listen on localhost, but your localhost doesn’t resolve to loopback, but to your static IP?)

*See Syncthing Configuration — Syncthing v1.23.2 documentation

Changing gui->address to the static IP in the config file fixes the issue. However, since I never explicitly changed anything related to my network in the config prior to just now, I’m still perplexed how it ever worked before.

In any case, thank you for your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.