TrueNAS Syncthing not finding Android on LAN


I have TrueNAS Core in use, and it detects my laptop and my pc in LAN, but for some reason it does not detect my Android.

I decided to try out the laptop with LAN. I downloaded Syncthing and just paired, no other setup, and the SyncThing found my phone through LAN.

What is so different with TrueNAS and Windows that Android app is visible in one, but not another. It would just be nice to be able to dump and pull bunch of data quikcly in LAN, vs through the internet.

Any ideas? Kind regards, A newbie

How did you setup Syncthing on TrueNas Core? Local discovery is a bit problematic on newer Android releases. If your server also has problems, that might explain it.

I clicked Plugins → Install → and mostly click Next. I just got it somewhat working by assigning the following Addresses for the device: dynamic, tcp://

Then I assigned in my router as persistant IP for my phone. Not ideal given if I will have more LAN devices and will have to go through the same.

What do you mean by “If your server also has problems”?

Did you turn off global discovery for one of the devices?

On mobile, yeah. This way I have connection to the laptop, but not the server. (When static IP not assigned)

I’m confused. You turned it off on your phone? Is it enabled on the server?

Yes, that’s right. Global discovery is off on the phone and on on my laptop and server. This results in phone finding the laptop but not the server.

I got around it by assigning the phone statis IP on my LAN, and telling it to the server. I am not sure why laptop didn’t require this setup even though laptop and server are running the same update (different OS, Windows on laptop and TrueNAS on server)

So it works for now.

Difficult to say why the two other devices behave differently, however local discovery on Android is broken, so if you disable global discovery there, then you basically end up with no discovery at all. If you disable relaying as well, then hard-coding IPs/hostnames is likely the only way the device will be able to connect.

I disabled the global discovery only to force the server to use LAN instead of global internet, as LAN speeds are much higher than cellular data. However the TrueNAS SyncThing did not want to see my phone, until I assigned the static IP and telling it to use it as well. Interestingly, it did not care about which I saw somewhere here in the forums, but wanted the specific 192.168.x.x:22000 IP I had marked for it.

Syncthing will still use LAN regardless of whether global discovery is enabled, unless the two devices can’t connect locally for some reason (e.g. firewall), of course.

For some reason that was not the case until the static IP. Yet on the laptop it worked even before the static IP assignment.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.