TrueNas scale and filesystem watcher errors

Hello,

I have installed the TrueNAS-SCALE-22.02.4. The first thing i did was to install the synching like that

The user and the group has UID 568 The synching works but i receive this message

Can anyone help me ? Thanks a lot

Sounds like you have a lot of directories and/or files under /mnt/MainPool/SynchingApp, or possibly TrueNAS has a really low default limit for inotify.

TrueNAS is built on Linux, and Linux’s inotify system has an in-memory queue that is used to hold watch requests. A program like Syncthing asks Linux to let it know when a directory and/or file has changed (it is how Syncthing knows when to sync a file shortly after a change).

The Syncthing FAQ has instructions on how to increase the inotify limits: https://docs.syncthing.net/users/faq.html?highlight=inotify#how-do-i-increase-the-inotify-limit-to-get-my-filesystem-watcher-to-work

Edit:

As an alternative to the Syncthing FAQ instructions, in the TruNAS management interface under System SettingsAdvancedSysctl, there is a setting for fs.inotify.max_user_watches (I don’t have a TrueNAS system, but the default might be 8192).

Increase the number to something closer to how many directories and/or files are in the Syncthing folder being watched. The higher the number the more RAM is used so arbitrarily setting it to 4 billion might not be a good idea. If you aren’t sure, 1048576 is a safe number and should cover most use cases (in case you’re curious, 1048576 = 1024 * 1024).

2 Likes