TrueNAS 12.0 RC1 permission denied

I have followed many how to on the internet and youtube and can not seem to get Syncthing to work.

I get "Failed to create folder root directory mkdir /: permission denied

there is a user sync uid 983 that has rights to the storage pool SyncThingData.

I have uninstalled and reinstalled three times. Removed the pool folder and rebuilt.

Is this a bug in TrueNas 12 RC1 ??

Why are you pointing syncthing at the root of the filesystem? Surely you create the pool and mount it at some specific location?

source is: /mnt/TANK/SyncThingData destination is: /mnt/TANK/iocage/jails/SyncThing/root/media/SyncThingData

sync user and group have rights to source, runing shell and looking at destination with ls -la the rights are with root and wheel, from other posts that would be correct.

sync user has a uid of 983

I think this question is better suited for your nas forums.

Jails, acls etc are problems of your NAS, not syncthing.

Just to confirm, inside the jail the path of the above dataset would be:

/media/SyncThingData

So you should be trying to set up the syncthing folder at or below this mount point.

You should also check the ACL as well as the unix file permissions. If you have setup the dataset as a “Windows” share, or have changed the ACL permissions yourself then this could also deny access to the dataset.

Yes that is correct. I have rebuilt this now 5 times with the same result. I tried ACL permissions on two of the attempts with the same result. The examples on Youtube have Unix permissions, three attempts were that way as was the last one.

When I rebuild I remove the pool and un-install SyncThing then Re-install and create a new pool.

My last attempt followed Lawrence on Youtube step for step.

I figured out what I was doing wrong. When accepting the share from the computer on the NAS I was accepting the default folder it wanted to create and that was at the root of the jail. Added \media\SyncThingData\ to the front of the folder name and it all works.

I have been doing IT for 30+ years but can be newbe on some of this first time around.