Trash Can File Versioning not working

Hey guys. I am having a problem with the file versioning. The server device downloads a file (archlinux-2015.06.01-dual.iso) in base directory and then sync the file to the home device. After deleting the file on the server the home device don’t move the file to the “.stversions” folder but instead rename it to “archlinux-2015.06.01-dual.sync-conflict-20150629-234636.iso”

Description of devices I got two devices that use Syncthing to sync files. The server device has no file versioning, folder, master is check and file pull is random. The home device is set to trash can file versioning and clean out after is set to zero days, the folder master is not check and the file pull order is alphabetic.

It seems that the file got modified (even if its metadata such as modification times) while being removed?

I don’t think the files was modified Audrius. Just did a second test.

On the server I use wget to download "" After the file was sync on the home device I remove it on the server with the rm command.

I did not browse the file or access 7z1505-x64.exe on the home device in any way before I deleted it on the server and the file got rename to 7z1505-x64.sync-conflict-20150630-000711.exe

Perhaps worth an issue on github, if can reliably be reproduced.

So the problem happens on my Linux devices. I have just tried to recreate the problem on two of my windows machines and so far there was no problems. But will try to find a way to recreate the problem on my other devices

Found the problem but not 100% sure how I can fix it. It’s all to do with how a NTFS is mounted in Linux and that the file access permissions are different

You have the ignore permissions flag.

The file permission flag solved the problem. Thanks for helping me Audrius.