Transferring data through a different NIC

Hi all, I am running Syncthing v1.22.0 on TrueNAS and SyncTrazor on PC Windows 10 Pro x64.

Here is my question: How do I setup Syncthing transfer through a different NIC, specifically the 10GbE direct connection between the PC and Server?

My PC has two NIC. One is 1GbE and one is 10GbE. 1GbE is connected via Cat6 to the router. 10GbE is connected to the TrueNAS server 10GbE NIC via Cat6.

My TrueNAS server also has two NIC. One is 1GbE and one is 10GbE. 1GbE is connected via Cat6 to the router. The 10GbE is connected to the PC 10GbE NIC.

I am able to transfer files between Veeam through the two 10GbE NICs between PC and Server. I can access the TrueNAS through the 1GbE NIC form the PC using 192.168.1.x and through the 10GbE NIC from the PC 192.168.0.x.

So far so good and as to why I need such heavy transfer speed is because my data can get to Tb territories working with Bioinformatic datasets.

By default, it is going through the 1GbE to the router and 1GbE to the PC which cripples my internet.

Here is what I have tried:

  1. I have tried changing the remote device Addresses under Edit Device>Advance>Addresses to tcp://192.168.0.x of both PC and Server, but data still goes through the 1GbE route.

  2. I tried changing the Advance Settings>Connections>Sync Protocol Listen Addresses to the 192.168.0.x but that really messes thing up and I had to reinstall Syncthing to get it back online.

Thank you for your help in advance.

This should be a matter of getting syncthing talking to the right addresses. I would set the listen address as you tried, correcting whatever went wrong in that part of the setup, and set a static address for the other side - to avoid automatic discovery and related guesswork. Do this on both sides.

The addresses have a syntax, which is similar for both the listen address and remote device address. Disregarding all the nitty gritty, you should be fine to set them to tcp://192.168.x.y:22000, with the appropriate x and y of course.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.