TLS mod v1.6.0-rc.1

With v1.6.0-rc.1 it seems anything has changed regarding https:// connections on localhost, I can not longer use my current Firefox, if “https” in the GUI part is activated. On Chrome is running and must deactivate that feature to have any connection in Firefox, now with

What prevents you from using Firefox? No crystal ball, here.

I installed Firefox to test now and it seems fine to me.

I did not say that I would be prevented, but something has apparently changed.

I reach my servers with v1.5.0 with https://IP:8384 and on my Windows computers with v1.6.0-rc.1 I only reach the GUI with http://IP:8384, but with v1.5.0 it was also possible to use https:// there.

So I wonder if TLS has been adjusted or where I need to search.

I’ll try again: what error or problem are you seeing.

If I use https://IP:8384, no loading of the GUI:

It’s the usual Firefox failure page when connections don’t work.

I suspect it’s not, because SEC_ERROR_INADEQUATE_KEY_USAGE is a fairly odd and specific error. Googling that gives various results with Firefox and self signed certs. You can try removing the Syncthing https-{cert,key}.pem files so that it regenerates a new certificate, or do the various things suggested on the internet.

Thats the problem. It can be any problem, I got only the difference between v1.5.0 and v1.6.0-rc.1

To stop Syncthing, delete the two files, start Syncthing again, the files are recreated, dont solve the problem.

If working on your side, I dont know. I think is a specific Firefox problem, because with Google Chrome, MS Edge, MS IE it runs.

How about trying under either a different profile, or a different installation of Firefox? Then you shall know whether it is this particular installation to cause the problem, or not.

Alternatively, you could also start Firefox in Safe Mode (, and see if there is any difference there.

For a clean installation, you may also try Firefox Portable (, Windows only), so that you can be sure that it will not mess with your current profile.


There is no difference. Also with a second Windows computer with Firefox there is the same issue.

It seems is only a Firefox issue. But for that I ask for relevant changes from v1.5.0 to v1.6.0-rc.1 to have some ideas for activities to solve the problem, maybe TLS details in Syncthing have changed or something like that.

We made no TLS-relevant changes. It’s built with Go 1.14 whereas previous versions were built with Go 1.13.

Can you still access a 1.5.0 installation with Firefox? I’m asking to verify that the problem isn’t that Firefox upgraded itself. Though, still, my firefoxes work with my syncthings :man_shrugging:

Yes, at my Synology´s the https:// works. Okay, no problem now, we will see. :raising_hand_man:

I did some tests with Firefox 76.0.1 on Windows, syncthing 1.5.0 and 1.6.0-rc.1, using multiple self-signed certificates generated by syncthing (an old 2017 RSA cert and a recent ECDSA) and everything works for me.

Are you by any chance running some type of (local) proxy that intercepts https? Those can be pretty broken…


Just for the record, I have just checked with fresh installations of Syncthing v1.6.0-rc.1 and Firefox 76.0.1, and the Web GUI seems to open with no problems under https.


Antivirus doing something like that (broken or not) come to mind.

Also with switching off of the Antivirus software, no change. Is not understandable, I use also v76.0.1 and without any Proxy settings. With all other browsers is running.

I suspect it’s to do with firefoxs’ update. My ‘accounts’ computer was on online banking this morning all fine, now after it did an update I can no longer get on the banking website, says the connection is insecure

Suspect it was coincidental to what you were doing on Syncthing.

1 Like

My you can check also with Google Chrome, MS Edge, MS IE, which run on my side with https://.

Anyway strange, Version 76.0.1 is from 8.5.2020 and up to yesterday was no problem. Problem I got with the new Syncthing RC.

Is the system clock set correctly?

Yes, correctly setted.

1 Like