TLS handshake error

Hi there. I have set up Syncthing on a server and at home and I’m having trouble connecting to the server’s web GUI. In a terminal it looks like this:

2014/06/22 05:17:39 http: TLS handshake error from IPADDRESS: tls: first record does not look like a TLS handshake
2014/06/22 05:17:59 http: TLS handshake error from IPADDRESS: EOF

When attempting to visit SERVERIP:8080 my browser downloads a tiny file. I was able to connect to the GUI before I enabled TLS.

I’m getting that particular feeling where the solution to this is incredibly simple but I can’t seem to work out how to make my browser realise I need to enter a password to access this IP and not to just dowload a tiny unreadable file.

Any help is greatly appreciated :smile:

You probably need to type https://localhost:8080/, where your browser defaults to http://.

Getting and (when using https) after trying to connect to either http://:22000 or https://:22000.

In the config.xml, tls is set to false,

<gui enabled="true" tls="false">

Below that, the listenadress is defined to .

I’m trying to access it over the internet and not via localhost.

The port is open and should be reachable.

As above, you want to use the GUI port with your web browser. To access it from not-localhost, change the config section that you quoted to <address></address>.

1 Like