Timeout and failed service errors on Synology Diskstation

I am using Syncthing between my DiskStation (usualy receiving) and a remote server (usually sending). It’s been working perfectly for years. Until last week. Syncthing speeds slowed down to a halt. From multiple MB/s to 10kB/s I don’t think I changed anything. FTP and torrents still have the usual speed on the server. The problem is only affecting Syncthing.

Here are some lines I find suspicious in the logs on DiskStation :

2020-12-09 18:27:06 UPnP parse: dial tcp i/o timeout
2020-12-09 18:27:07 Detected 0 NAT services
2020-12-09 18:27:09 Listen (BEP/relay): Get "https://relays.syncthing.net/endpoint": net/http: TLS handshake timeout
2020-12-09 18:27:10 Relay listener (dynamic+https://relays.syncthing.net/endpoint) shutting down
2020-12-09 18:27:15 Relay listener (dynamic+https://relays.syncthing.net/endpoint) starting
2020-12-09 18:27:15 c.S.listenerSupervisor: Failed service 'dynamic+https://relays.syncthing.net/endpoint' (1.000000 failures of 2.000000), restarting: true, error: "{dynamic+https://relays.syncthing.net/endpoint dynamic+https://relays.syncthing.net/endpoint} returned unexpectedly", stacktrace: [unknown stack trace]
2020-12-09 18:27:30 quic:// detected NAT type: Port restricted NAT

Could this be a hint of what’s causing the problem, or is it unrelated? is my router. (I rebooted it but I’m still getting similar errors.)

I would appreciate any help. I’m really lost here.


My router’s firewall is set to “NAT only”, which seems to be the least restrictive setting. DiskStation doesn’t have much of a firewall either.

Sure, but it can’t even connect to relay pool servers, so something is blocking outgoing network traffic, and based on the upnp failure my guess it would be the device itself not the router. It’s for you to figure out why that happens.

1 Like

Which Syncthing versions are used on the devices?

Which Synology is it and with which DSM or update status?

Which Syncthing package is installed on the Synology, from Safihre or Kastelo? Or is a manual installation, it means not over package center?

I assume the remote server is a linux server, right?

I know a lot of questions, but a little more background could be good for the support.

1 Like

Both devices use v1.12.0

Synology ds212j DSM 6.2.3-25426 Update 2 Safihre package

Ubuntu remote server. Another user is currently syncing with that same server with decent speeds, so the problem is definitely on the Diskstation side.

Okay, that are fine all, maybe without Syncthing v1.12.0.

Doe you think about, that last week your problems arise with any change from a version to a further, I mean maybe from v1.10.0 to v1.11.x or v1.12.0?

Doe you check in the DSM the Ressource-Monitor > Task-Manager > sort CPU(%) to have a view to the single task? Maybe a task is blocking other tasks, among others also Syncthing.

Next question would be, how many peers you have in your Syncthing GUI and how much files and folders are managed from the DS. I ask for that, since the DS have 256 MB RAM.

I’m not sure when I updated to 1.12 on the DS.

DSM 6.2.3-25426 is very recent. That update happened around the time when my Syncthing trouble started. (I don’t remember what came first) Maybe it could be related?

In the Resource Monitor, synthing is the main task. Memory is around 60%. Nothing alarming.

The other notable task is indexing (synoindexplugind) : last month I requested a reindexing of my photo archive. It’s taking forever. It ran for a couple of weeks without impacting Syncthing.

Regarding the number of peers in the GUI, is this what you mean? Listeners 3/3 Discovery 3/5

One more thing that could be relevant : I first noticed the problem when I tried to sync a very large file (120GB!) When I noticed things had slowed down, I found discussions mentioning how Syncthing could have an issue with larger files, so I deleted the file on the server. Since then, I restarted Syncthing multiple times, also tried pausing and resuming sync. Maybe the DS is still waiting for chunks from that file? I’ll try a rescan.

The base release DSM 6.2.3-25426 is from May 2020, but the Update 3 is pretty new and is released approx. a week ago. You can check which update is installed in the control panel.

Then I would switch off the indexing service as a test if we are talking about the same thing. An indexing status may be displayed at the top right in the status line and you can also stop and start there.

By peers I mean “Folders” in the upper left corner of the GUI. There is the question of how much folders you have. Then under “This Device” there is Local State (Total), it would be good to know what is displayed. Maybe a screenshot of the whole thing would be good.

The subject is, every file and every directory has to be managed by Syncthing, but 256 MB of RAM may be a bit too little at some point. Then a chunk of 120 GB was a maybe a bit to much.

I cannot judge how it behaves with the deletion etc. Are there status indicators such as “Out of Sync” or information about items that have not been synchronized?

It worked!

I stopped the indexing service, and Syncthing speed instantly went back up to normal.

$ sudo synoservicectl --stop synoindexd

I’ll resume indexing once the synchronization is complete.

Thank you very much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.