The proxy can't hide the real ip address

Hi,everybody.I tried to hide my real address by a proxy or tor by export all_proxy=socks5://127.0.0.1:9050 and export ALL_PROXY_NO_FALLBACK=1, setting global proxy of system and changing the proxy model of my router to global proxy, but the truth is that real ip address was exposed to another device. Maybe it’s the update of syncthing from 1.16 to 1.17.Before upgrading,I’m sure that the ip is hidden not my own ip address.The two device is in different nat network. Does anyone have a solution or advice, please?

Sending device: Ubuntu20.04, x86_64 Receiving device: Android 10, arrch64

You can’t really hide your ip, unless you disable things like discovery as well.

The fact you are connecting out via a proxy doesn’t mean that syncthing will not connect to discovery add advertise all of its ips.

Would the sync connections even use the proxy?

They would, we do support outbound connections going via a socks proxy. But that doesn’t cover incoming connections.

1 Like

Sure,thanks for you reply.