Testing ST - trying to decrypt test file

I have two instances of TrueNAS running ST. They are connected and I was able to sync a single photo both trusted and untrusted, different folders. I have made these folders SMB shares so I can see them from Windows. I would like to decrypt the encrypted file on the receiving TrueNAS machine to test that I can recover my files if most machine fails. I open the shell for ST and I have tried

syncthing decrypt --to=/encrypt --password test /decrypt --folder-id hsfgr-ues6c

syncthing decrypt --to /encrypt --password test /decrypt --folder-id hsfgr-ues6c syncthing: error: Yellowstone2003 023.jpg: loading metadata trailer: seek /decrypt/Yellowstone2003 023.jpg: invalid argument

but i get an invalid argument. All of these folders are mount points in my trueNAS app install for syncthing.

I tried this

syncthing decrypt --to /encrypt --password test --to /decrypt --folder-id hsfgr-ues6c

and got this error syncthing: error: expected “”

Nothing here is critical, I am jsut trying to make sure I can recover my encrypted data from a remote machine it needed, otherwise encryption is not an option.

thanks

It looks like you’ve switched the to and from arguments. Yellowstone2003 023.jpg is not a Syncthing-encrypted file, unless you’ve moved and renamed it yourself.

Thanks for taking the time to help me. Here is a screen shot of ST with the receiving folder that is encrypted.

image

here is my updated command

/ # syncthing decrypt /syncthingencrypt --password test --to /syncthingdecrypt --folder-id hsfgr-ues6c syncthing: error: Yellowstone2003 023.jpg: chmod /syncthingdecrypt/Yellowstone2003 023.jpg: operation not permitted

here are the mount points in my app setup in truenas

here is my SMB share in windows showing the encrypted file in the encrypted fold which is mapped to the syncthingencrypt

image

I am not an expert in linux or command line.

permissions ^

ok, I am getting somewhere. next question. I setup ST with my admin user (950)

admin is local admin with full read write excute

I have given full control to admin, root and chris for decrypt

good news the file is now showing up in decrypt but it is 0KB.

Is ST using a different user that i need to get premission to Decrypt?