System cannot find the file specified

I’m syncing between synctrayzor and Android. I’m trying to do a one way sync from my phone’s camera folder to a folder on my computer that already has most of the files from my phone’s camera, plus older stuff.

I get this error (for 998 items) 2022/11/15 19:14:31 INFO: Puller (folder “Camera” (t5sch-qziwr), item “20210912_094828.jpg”): syncing: finishing: opening temp file: open \?\C:\Users.…\Camera~syncthing~20210912_094828.jpg.tmp: The system cannot find the file specified. [5FNPU] 2022/11/15 19:14:31 INFO: “Camera” (t5sch-qziwr): Failed to sync 998 items [5FNPU]

Earlier I had issues with a sync and it left a ton of tmp files which I deleted. Maybe it’s looking for those? I already restarted the app on computer and phone, removed the synced folder from each, tried to initiate it on each end, but I still have the 998 errors of 1661 files.

Any ideas?

I tried switching to syncthing-fork on android and enabled the camera sync from there, and I had the same issue.

Since this is on Windows, and the files seem mysteriously missing when they shouldn’t be, I’m inclined to suspect antivirus. Maybe it quarantines the temp files before Syncthing is done.

1 Like

You are amazing. I just use Defender, and it didn’t pop up any warnings or anything, but sure enough when I went in I had a ton of low risk items blocked. Once I allowed syncthings through, the camera folder started syncing. It’s still odd when everything else worked, just not this one folder (which was nested in another folder which DID work), but it’s all good now!

Thank you!

2 Likes