Synology NAS Syncthing permission issues.

So, I have Syncthing installed on my Synology NAS (DS418) and my Windows 10 PC. On the NAS, I have syncthing installed on volume 2. But the folder I am trying to sync from my PC needs to be stored on volume3 on the nas. So, I went into the WEB GUI on the NAS, and changed the default path from ~ (Tilde character (~) expands to /volume2/@appstore/syncthing/var.) to /volume3/Shared But syncthing always tells me there was a problem creating the folder, and that the path doesn’t actually exist, even though I went in and made the “Shared” folder manually.

I’ve tried giving the sc-syncthing group full permissions over everything, creating and giving the sc-syncthing and syncthing users full admin permissions (I know it’s not recommended). Editing the permissions of the shared folder and volume 3 to allow the group read/write… And yet it’s still giving me the same errors even after a restart.

Failed to create folder root directory mkdir /volume3/Shared: permission denied
Error on folder "Archive" (rmnyi-7mgdf): folder path missing

What do I do? I have the Synocommunity package installed by the way. It’s version 1.2.2-17

Search the forums, this question comes up often.

That’s why I’m here. I looked through multiple threads and none of them seemed to have a solution for my problem. E,g I read: Problems using Syncthing on Synology Other threads say to simply make a user named syncthing and put it in the admin user group. But i’ve tried all that… Nothing works.

Well, how do I fix it? Can I ssh into the NAS and give you a log or something?

Synology sets all kinds of ACLs by default. Best to leave these in place.

However, The Anime folder shouldn’t be in /volume3/Shared? It should be something like /volume3/Anime if it’s on the third volume. Share that folder.

Anime is just the volume label for volume 3. It’s not a folder. The folder structure on Volume 3 is: /volume3/Shared/Archive This volume is completely empty at the moment and I’m trying to sync the archive folder from my PC to it. The folder on my PC is set to send-only.

NAS:

PC:

I’ve tried changing the owner here of the shared folder to admin (with syncthing user in admin group) or just giving ownership to syncthing user itself.

Yeah no idea, that’s above my pay grade of Synology-ology. You can ssh in and look at the actual paths, permissions and ACLs and perhaps gain some clarity.

Ah, i figured it out. Synology makes a directory with the name of the volume. So the path should’ve been /volume3/Anime/Shared… Working now.

I recommend that you always copy and transfer the directory paths from the file manager, then capitalization and completeness etc. are excluded. This works and saves time.

In addition, when creating a peer at the path with the respective 2-3 initial letters of the subdirectory and 1x back button, you can show and select an overview. So is my working, because I´m not sure the handling with the folderlist.

You are using Syncthing from SynoCommunity. This normally has no user “syncthing” and the internal system user “sc-syncthing” is usually not used. You should use the group user “sc-syncthing”. And you have to check whether the rights are inherited in the subfolders.

I have an SSD as volume 3 and have created a main directory with a subdirectory. It is accepted flawlessly. This has nothing to do with the ACLs.