Synology NAS DS918 + with DSM 7.0 Windows: Syncthing icon does not appear in installed applications

On Synology NAS DSM 918+ with OS DSM 7.xx, after installing from Synology Package Center> Community Packages, the Syncthing app - which also works well between android and NAS,

The Syncthing app is not shown in the installed applications.

The only way to view it is to open the “Package Center” and enter the name “Syncthing” in the search bar of applications

Consequently, if Syncthing has modifiable options - NAS side - not being able to open the application, the options are not available.

Does the defect of the missing display depend on the OS of the NAS, DSM 7.xx, or does it depend on Syncthing?

Which package source (SynoCommunity, Kastelo, Synology) did you get it from and what is the version number?

The icon ususally only shows up when it is installed and running. I don’t know what the labels mean, but at least the other icons show “Apri” instead of “Installato”. So make sure the package service is actually started.

I haven’t tested an Syncthing package on DSM7 yet, so there might be differences I’m not aware of.

Source From Synology.

In Synology, from what I have been able to see, the installed applications are all visible in the collection of installed applications, as in the dark image I sent, the only exception of which is Syncthing.

Syncthing is installed on Synology and is running as you can see from the attached image here.

The image was not opened from the collection of installed applications, where Syncthing should be visible, but only by looking in the Package Center, from which it can be seen that it is running and its version 1.17.0-22.

I see the new version is 1.18.3, but I don’t see packages made to be installed on DSM 7.0, the Synology OS …


I’m not sure if this is as a result of a recent Syncthing package update, or of DSM7, but Syncthing no longer shows up in the app launcher for me anyway.

Instead, you can just click on the URL in the Syncthing package info to open the GUI:



So we’re two that we don’t have Syncthing in the app drawer. I don’t know whether to ask Synology … however everything works quite well.

You’re right … Syncthing management can be started from the link. In fact, I used that link to launch the interface on the NAS and set up all syncs.


Your dark picture shows the start menu, I suppose. Syncthing in my DSM 7 is displayed in the start menu. However, you can add an icon via the console, but now I would also have to use the search function


Hi Andy, thanks . . . My dark picture shows the list of DSM 7.xx installed packages, the one that opens by clicking on the top left with the four small squares …


at this point it would be useful to know how to use the terminal to restore the Syncthing icon (which does not appear even after uninstalling and reinstalling) but I believe this topic is OT … :slight_smile:

You’re not running a package from Synology, but from SynoCommunity. I know for sure because of the version number and because my name stands beside it on your screenshot :wink: There is not a new SPK release for every Syncthing version. But the package leaves Syncthing’s internal update routine intact, so even though the package says v1.17.0, you will actually be running the latest stable binary in the background. Look at the Web GUI to verify the running version.

Sorry I can’t really tell why the icon is missing. If the GUI is reachable on the default port 8384, then DSM should start showing the icon. Maybe that test fails for some reason? Any custom firewall rules?

It’s working alright for me, but still on DSM 6. There were no changes to the SPK for a while, maybe something changed in recent DSM7 updates…

One more thing I just thought of: If you’re logging in as a regular (non-admin) user, then you need to assign a user privilege first. In the Control Center:


Yes, I’m using the SynoComunity version, which is the only one available for Synology.

The GUI shows v1.18.3 - which is the latest stable version and is reachable from port 8384 by default, but DSM does not show the icon.

I don’t have any particular custom firewall rules.

DSM7 has changed a lot from DSM6. I think I remember that long ago the Syncthing icon was visible in the app drawer.

I log in as an administrator.

Thanks for all…

Magically, the problem solved itself:

it was enough to open the three ports used by Syncthing in the firewall of the Synology NAS: 22000, 21027, 8384 !

Up until now it hasn’t been necessary as Syncthyng worked flawlessly without opening those three ports …

If anything, now I wonder how it ever worked with the doors closed and if there is a real need to keep them open. . .

cheers . . .


Glad you could solve it. As I said, what matters is the port 8384. If you had it accessible from your local LAN, then I assume it was already opened in the firewall. Might have to do with different zone definitions? Localhost is different from any other local LAN address, IPv6 vs. IPv4 might come into play, etc. At least on my Synology, enabling the firewall without any rules configured still allows the icon to show up while the service is running.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.