Synology Moments + Syncthing


I’m running syncthing to do a oneway sync to the synology of all my photos to the synology moments folder. I’m reading that moments doesn’t touch the files, but without any edits from Moments, I’m wondering if I’m doing something wrong as the sync just stops and produces an error saying

no connected device has the required version of this file

What I’m trying to do is just copy/sync the photos on my desktop to the synology so I can see them through moments. I just want to view the entire photo collection of my photos on the synology in moments.

Anyone have similar issues or potentially better methods? I tried synology drive, but was extremely slow to sync for me and I want to keep my own folder structure on the mac.

If there are no other problems with Syncthing on Synology, it might be an permissions problem. Check these in the homes folder. Moments is structurally part of Drive and all data are in the home folder.

Is there something similar in other folders? Which DSM do you have installed and which version and package of Syncthing?

Thanks for the reply!

All the other syncs seem to be fine and syncthing has been running relatively smoothly. Sometimes it says “disconnected” but seems to be syncing, so not sure what’s happening there. The syncthing user group has all permissions. I feel like the moment I run moments, the sync stops and produces an error. Do xmp files create an issue for moments, or does it just pickup raw, jpg and video files and ignores others in the directory?

I’m on the 920+ with DSM 6.2.4-25556 and syncthing v1.16.1.

As default setting, Drive and Moments are included in the indexing in the DSM. This is managed in “Universal Search”. I’m not sure, but it is possible that this indexing might have such an impact. For the test, I would turn it off and watch what changes.

The home folder and its structure is a special feature in the DSM anyway, so tests are required to get on the track. Otherwise, if Syncthing in other cases works well for you, I would initially assume so.

Somehow seems to be ok now. Might be some ignorelist issue with the @eadir where it seems to be writing a bunch of files.


To have a smoothly process, it would be good to have some ignore patterns as standard in each folder:

System Volume Information

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.