Synology | Error while trying to start filesystem watcher....

I found some similar threads to the message

Error while trying to start filesystem watcher for folder “xxx” (yyy), trying again in 1min: error while traversing zzz: permission denied

But no discussed solution helps finally.

The obvious solution with the Synology ACLs didn’t work either. It doesn’t matter whether with or without “+” at the end of the permissions, i.e. with or without Synology ACLs. The message mentioned appears anyway. But what amazes me:

  • Only in some of the main directories, e.g. /volume1/subdirectory_1
  • Only a few of the many main directories are affected, although they all have similar rights.

The corresponding main directories are also displayed as “current”. Everything seems synched.

It sounds like it doesn’t have permission to look at the files, filesystem watcher or no.

The question is why. I have started various tests. In principle, the user group “sc-syncthing” is stored in the main directories concerned. This is usually inherited in all subdirectories. In all cases there are also other user groups or users or the system.

Syncthing-1 Syncthing-2

In the first test, I removed the ACLs in the subfolder by setting the group and the owner to “root” in WinSCP and, together with the rights, octal to 0777, it means drwxrwxrwx. Then I inherited the Synology ACL in the main folder in Synology DSM back into all subfolders. This steps often helps with problems. But not in these special cases. The subfolders again had d---------+ with the “+” at the end.

So I repeated that and set the group and the owner to “sc-syncthing”. The subfolders again had d---------+ with the “+”, with the same result.

Then I removed the ACLs in the subfolder again and only left the Synology ACLs for the main folder (d---------+), because of the Synology specific access. However, all subfolders had octal 0777, so drwxrwxrwx, so without a “+”. But again with the same result.

Therefore, for me the Synology ACLs are irrelevant to these Error message.

I try different issues, up to now without success, also is there no relation to the volume filesystem EXT4 or BTRFS. On both I have the problem.