SynoCommunity package Permission on folders not allowing shared folder to be used by synchting

Hello. I asked for help before but I basically have given up on docker because after reading and trying dozens of different things I can’t get docket to work. I now installed the SynoCommunity package and I am running into the same problem. I installed the packer and I grant permissions on the folder: “/Volume1/homes/username/Photos” to both the syncthing user and sc-syncthing__PKG_ users read and write permission to said folder but every time I create the share I get an error that there are no premissions to wrote - not allowed, this is the actual error:

023-08-04 10:47:49: Failed to create folder marker: open /volume1/homes/username/Photos: permission denied

2023-08-04 10:47:49: Error on folder “photos” (photos): open /volume1/homes/username/Photos: permission denied

I have read the wiki but I find no definite answer on how to actually set the permissions for a specific folder and I am not sure if I have to allow the user permissions or what. I am trying to use syncthing to sync files betweek my synology and truenas remote boxes. What I ended up doing to achieve this between synology and truenas was to map a network drive on a windows machine and then use synthing thing on my windows box to sync with truenas. I would like to be able to leave off my windows machine to make this happen. Anyone can help with how to configure premissions on the synology DSM 7.1.1-42962 Update 6

Any help is appreciated.

Have you tried using the “Permission Inspector” tool available within DSM’s File Station? Select Action > Properties > Permission > Advanced options > Permission Inspector. You should be able to find the exact permissions applicable to a user or group this way. When setting them on a folder, make sure they get inherited to all children. Definitely enable the “Ignore permissions” option within Syncthing’s configuration for each shared folder. Otherwise Syncthing will apply a set of basic permission rules, erasing all ACLs set via File Station along the way.

I can’t say much about DSM 7, as I’m not using it yet. But AFAIK the correct way to assign Syncthing permissions for the SynoCommunity package is through the group named sc-syncthing. I have no other Syncthing-related entities in my ACLs and it works fine.

Thank you for replying. I know I have seen the sc-syncthing group before but I no longer see it. The group I do see is: sc-syncthing__PKG_ and I have given it read and write permission to the one fodler I want to sync and I ignored the inhereted permission as you indicated but to no avail. Could I add that group manually?

I just went back on to the unit and uninstalled the package and installed it again allowing the user above to have permission to the folder: 2023-08-07 17:22:13: Failed to create folder marker: open /volume1/homes/user1/Photos: permission denied

2023-08-07 17:22:13: Error on folder “photos-full-open” (photos-full-open): open /volume1/homes/cuser1/Photos: permission denied

The only user I see is sc-syncthing__PKG_ but no plain sc-syncthing user/group

That really looks like a bug in the packaging scripts. I haven’t been following closely what has changed on the spksrc side (GitHub - SynoCommunity/spksrc: Cross compilation framework to create native packages for the Synology's NAS) recently. Don’t know when I’ll have time to catch up there, but you might want to open an issue there (please @mention me for notification) or ask for help on their Discord channel.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.