SyncthingRunnable(...): Syncthing has crashed (exit code 11)


#1

E-book reader Onyx-Boox MC_Cleopatra3 Android 4.0.4 kernel ver. 3.0.35 jenkins@ubuntu-build-server #1 Fri Jul 21 18:58:40 CST 2017

what happened

Syncthing don’t letting me customize and use itself.

what you expected to happen instead

I’ve expected the same exellent synchronization like on smartphone.

and any steps to reproduce the problem.

It probably be better to show the photoes…

Sorry if I doing something wrong. I just want to be more understandable. Screenshots couldn’t be upload for unknown reasons. I can give a links on them 1. 2. 3. 4. 5. 6.

CatLog output

SyncthingRunnable

04-27 13:53:50.670 I/SyncthingRunnable(3669): Syncthing exited with code 11
04-27 13:53:50.670 W/SyncthingRunnable(3669): Syncthing has crashed (exit code 11)
04-27 13:53:50.890 I/System  (3669): 	at com.nutomic.syncthingandroid.service.SyncthingRunnable.run(SyncthingRunnable.java:152)
04-27 13:53:51.740 I/SyncthingRunnableIoNice(3669): ionice performed on libsyncthing.so
04-27 13:53:51.740 I/System  (3669): 	at com.nutomic.syncthingandroid.service.SyncthingRunnable$1.run(SyncthingRunnable.java:205)
04-27 13:53:51.740 E/SyncthingRunnableIoNice(3669): Failed to set ionice 1
04-27 13:54:48.600 I/SyncthingRunnable(3669): Syncthing exited with code 11
04-27 13:54:48.600 W/SyncthingRunnable(3669): Syncthing has crashed (exit code 11)
04-27 13:54:48.620 I/System  (3669): 	at com.nutomic.syncthingandroid.service.SyncthingRunnable.run(SyncthingRunnable.java:152)
04-27 13:54:49.570 I/SyncthingRunnable(3669): Syncthing exited with code 11
04-27 13:54:49.570 W/SyncthingRunnable(3669): Syncthing has crashed (exit code 11)
04-27 13:54:49.720 I/System  (3669): 	at com.nutomic.syncthingandroid.service.SyncthingRunnable.run(SyncthingRunnable.java:152)
04-27 13:54:49.740 I/SyncthingRunnableIoNice(3669): ionice performed on libsyncthing.so
04-27 13:54:49.740 I/System  (3669): 	at com.nutomic.syncthingandroid.service.SyncthingRunnable$1.run(SyncthingRunnable.java:205)
04-27 13:54:49.740 E/SyncthingRunnableIoNice(3669): Failed to set ionice 1
04-27 13:54:50.530 I/SyncthingRunnableIoNice(3669): ionice performed on libsyncthing.so
04-27 13:54:50.530 I/System  (3669): 	at com.nutomic.syncthingandroid.service.SyncthingRunnable$1.run(SyncthingRunnable.java:205)
04-27 13:54:50.530 E/SyncthingRunnableIoNice(3669): Failed to set ionice 1

SyncthingRunnableloNice

04-27 13:53:51.740 I/SyncthingRunnableIoNice(3669): ionice performed on libsyncthing.so
04-27 13:53:51.740 E/SyncthingRunnableIoNice(3669): Failed to set ionice 1
04-27 13:54:49.740 I/SyncthingRunnableIoNice(3669): ionice performed on libsyncthing.so
04-27 13:54:49.740 E/SyncthingRunnableIoNice(3669): Failed to set ionice 1
04-27 13:54:50.530 I/SyncthingRunnableIoNice(3669): ionice performed on libsyncthing.so
04-27 13:54:50.530 E/SyncthingRunnableIoNice(3669): Failed to set ionice 1

Other log files was empty

Version Information

App Version: hmm.. what App do you mean?
Syncthing Version: v0.10.8
Android Version: Android 4.0.4

Thank You very much for help! Syncthing is very needed and important program for me.


Unable to open log device '/dev/log/main': permission denied
(Audrius Butkevicius) #4

You should provide the full log


#5

Alright. I’ll try it now

Update! Full log is here

Forum said that new users, like me, can’t attach files


#6

I am trying to take the logs with Android SDK way… Want my answers to be more usefull.


(Audrius Butkevicius) #7

So this crashes at the linker because the version of Android you are using does not support position independent code (PIE) at the linker and our go binaries are built with PIE.

There is some magic workaround shipping a 4.1 linker together with the app, but I am pretty sure nobody is going to explore that avenue to support an 8 year old android version.

You need atleast Android 4.1 for this to work most likely.

You could venture in trying to build syncthing yourself without PIE.


#8

Thank you very much for your help. I am still get logs all this time, but failed on that. It seems that Onyx-Boox will not update this device to 4.1. Thats pity.

If only I be a programmer!


#9

My friend from Onyx-Boox forum tried to install and use Syncthing on Onyx-Boox Darwin 4 under Android 4.2. It worked well, as he said and it was looked on screenshots he sent.

Sorry for disturbing and thanks a lot for Syncthing


(Jakob Borg) closed #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.