syncthing zombie process


I had an instance of syncthing running but (don’t know what happened) it crashed, killed it and is now a zombie process owned by PID 1. When I try to run syncthing in the same machine it gets stuck

[start] 2023/09/04 10:10:35 INFO: syncthing v1.23.7 "Fermium Flea" (go1.20.7 linux-amd64) 2023-07-31 03:45:37 UTC

and if I try to run in another machine in the same cluster sharing the same disk space I get (a trials of)

[start] 2023/09/04 10:03:46 INFO: syncthing v1.23.7 "Fermium Flea" (go1.20.7 linux-amd64) 2023-07-31 03:45:37 UTC
[start] 2023/09/04 10:03:47 INFO: Using large-database tuning
[start] 2023/09/04 10:03:47 WARNING: Error opening database: resource temporarily unavailable (is another instance of Syncthing running?)
[monitor] 2023/09/04 10:03:47 INFO: Syncthing exited: exit status 1

I’m not the administrator of the machines so I cannot reboot the first one. Is there anything I can do? Maybe delete a lock file or something like that? Would that be safe?


How do you know its a zombie? Sounds like the monitor process got killed/died and it got orphaned.

I assume you tried killing it?

Yes, I tried killing it. Right now what I have in this machine is

meaning all of the syncthing processes are owned by the init process and I have no way of getting rid of them.

State D means means it’s stuck waiting on I/O, maybe a dead NFS filesystem or a hardware problem if it’s not temporary (busy disks).

Yes, it could be some NFS/hardware problem since dmesg shows all kinds of weird errors and warnings.

So, is there any “workaround” to the state D/Z processes? (unfortunately, reboot is not an option :face_with_diagonal_mouth:)

There is no workaround, this is a kernel/system issue.

I meant in terms of “telling” syncthing to ignore that there is another (sleeping/dead/zombie) instance running. Maybe deleting some .lock file or something of the sorts…

Don’t do that, lest you invite a zombie apocalypse if/when those processes get unstuck and return from the dead. The database lock is there for good reason. Instead complain to your system administrator.

OK, it makes sense :grinning:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.