Syncthing won't start on my Synology!!

Hello guys. I have a Synology DS916+ I decided to install a few weeks ago this Syncthing package from here It was running well!! The app even self updated. Yesterday I decided to make a minor firmware update on my DS, to the last version, DSM 6.1-15047 Update 2 (before it was on DSM 6.1-15047 Update 1). After the update, I discovered that Syncthing was not started. I tried but no luck. I restarted the DS but again Syncthing won’t start.

I tried to search internet for a solution but I’m not able to find a solution.

I found here a similar problem to mine . When I try to execute “start-stop-daemon -b -o -c syncthing -S -u syncthing -x env HOME=/usr/local/syncthing/var/ /usr/local/syncthing/bin/syncthing – --home /usr/local/syncthing/var/” it says that command not found. I’m a bit limited on the linux side, but I found out that start-stop-deamon was located in /usr/local/syncthing/bin/, but even there when I execute that command, I get: “unknown user syncthing”. I even follow this: As a ‘fix’ (not sure it is a fix) I did the following:

Created user syncthing, put it in the sc-syncthing group and gave it access to the syncthing share
Logged in via ssh and executed sudo chown -R syncthing:users /usr/local/syncthing

but no avail…

Can anyone help me?!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.