syncthing + wireguard help

Ive setup wireguard between my server and another server. And trying to get syncthing communicating between the devices, but cant get them to see each other…

We have added the device id on each end and they dont connect. So then we have tried putting the ip in each end also. tcp:\vpn_wireguard_ip:port of the other machine… And still no luck…

How can I debug this issue?

Machine A local ip: vpn ip:

Machine B local ip: vpn ip:

SSH, VNC SMB etc all work fine, just not syncthing… I guess its an issue with the dual ip’s possibly?

I did notice these error on machine A

quic:// Handshake did not complete in time (18:34:45) quic:// context deadline exceeded (18:34:45) quic:// context deadline exceeded (18:34:45) tcp:// i/o timeout (18:34:35) relay:// relay:// tcp:// i/o timeout (18:34:59) tcp:// i/o timeout (18:34:35)

None of those are the mentioned addresses, so I suspect you might not have entered that correctly? (Screenshots help clarify. You’re saying tcp:\ here while the correct syntax is tcp:// and we can’t know if you just typoed it here or also in the config.)

If/when the address is correct “i/o timeout” generally means “firewall blocked”.

Strange! We just disconnected the vpn and after a while it automatically connected! I guess it was some routing issue with the vpn causing syncthing to not work?

Ill have to do some more testing…

Sorry yes, tcp:// was what was used (to much time using windows)

And now its back to the same errors as before… No clue whats going on here

Could you attach the syncthing log of one instance?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.