Syncthing will not install on Raspberry Pi2

My Raspberry Pi2 is running Raspbian Jessie Lite. I tried installing Syncthing using this guide but it just hangs at the line:

[NNK3Y] 06:45:38 INFO: Detected 2 NAT devices

If I kill the process there is no .config file to edit. Can anyone help?


Why do you think it hangs?

I have no idea - that was what I was hoping to solve with my question :slight_smile:

I mean, what did you expect to happen. From the message it just looks like it finished the startup sequence and is waiting for you set it up via the web ui.

I cannot access the web UI from my PC via the Pi’s IP address and also cannot locate any syncthing .config file when I searched with WinSCP. I also tried turning my firewall off.

The config is in ~/.config/syncthing/syncthing.xml for the user who started it. By default the GUI is only listening on localhost, so you’ll need to edit the config file or use an SSH port forward. What to edit etc is somewhere in the FAQ, I think.

I think I just located the config file - everything working now, thanks for the advice!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.