Syncthing Web Gui

Hi I have just solved a problem with your help

Now that the first step is solved other problems comes out

The gui from the web doesn’t work properly while the gui from the lan is ok

In the gui I have access from the web at the upper left corner near syncthing logo I read “(unknown)” while in yhe gui from lan I read correctly “ubuntu”

Other problem is that in the gui from web I read listerners “0/” while in the gui from lan I read listeners “3/3”

The third problem is that in the gui from web the menù doesn’t work…If I click settings no settings popup appears. The lan Gui menù works properly.

Webgui from web

Webgui from lan

Check the browser console logs.

It probably doesn’t like it not being accessed from localhost.

What you are doing is fairly dangerous. You are running syncthing as root and making it’s ui accessed via the internet. By default it runs without https, so your UI password can be intercepted, and then it’s fairly trivial just to take over the whole machine.

Now syncthing is not running with root

Syncthing has a password access and is https

The browser console log report this error:

   1. Request URL:

  2. Request Method:


  3. Status Code:


  4. Remote Address:

  5. Referrer Policy:


1. Response Headers

  1. cf-cache-status:


  2. cf-ray:


  3. cf-request-id:


  4. content-length:


  5. content-type:

text/plain; charset=utf-8

  6. date:

Sun, 24 May 2020 18:04:51 GMT

  7. expect-ct:

max-age=604800, report-uri=""

  8. server:


  9. status:


  10. x-content-type-options:


  11. x-frame-options:


  12. x-syncthing-id:


  13. x-syncthing-version:


  14. x-xss-protection:

1; mode=block

2. Request Headers

  1. :authority:

  2. :method:


  3. :path:


  4. :scheme:


  5. accept:

application/json, text/plain, */*

  6. accept-encoding:

gzip, deflate, br

  7. accept-language:


  8. authorization:

Basic ...

  9. cookie:


  10. referer:

  11. sec-fetch-dest:


  12. sec-fetch-mode:


  13. sec-fetch-site:


  14. user-agent:

Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36

  15. x-csrf-token-vz7dl:


Your issue is with fonts not being loaded, probably because of something like this:

I havn’t any load balancer so why the problem should be a fonts not loaded on cross domains ?

I have made a standard installation…and I haven’t htacces file

And if fonts is the cause why something is shown

Perhaps in the menu if I click on Advanced a part of the popup appears…

A reverse proxy needs to send certain headers for fonts to be loadable by browser. The UI looks fine, just the fonts look wrong.

Anyways, sorry, but I can’t help you here, I don’t know enough about apache.

Don’t know how…but this morning works after a chrome crash

:rofl: :rofl: :rofl:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.