syncthing slow on local LAN without relay

Hi,

I have read through the FAQ and a couple of threads on this, but I am still not sure if what I get is normal or I have configured something wrong.

I have a desktop computer (with SSD) and a server with proxmox (with zfs on all ssds as well)->ubuntu server → docker containers → syncthing (And another server off the home lan, but that should only increase performance, right? :))

The desktop computer and sevrer are both on the same LAN, but I get transfer speeds around 50Mbps. I have 100Mbps internet, so my first suspicion was that I was using a relay.

But this seems not to be the case: image
image

Here is htop on proxmox host:

and on the ubuntu guest: and guest iotop: image

What do you think is slowing down the transfer? Maybe saving unto a zfs dataset?

Honestly I am pretty new to the “self hosting” my services on my own server part, as I want to have more control over these kind of things. So I would appreciate any input to tracking this down as a learning opportunity. :slight_smile:

edit: In case someone is wondering, the RAM on the server should be okay (taken from netdata of host):

Also the desktop should be okay: image edit2: on the server:

2021-05-01 11:59:16 Single thread SHA256 performance is 237 MB/s using crypto/sha256 (237 MB/s using minio/sha256-simd).
2021-05-01 11:59:16 Hashing performance is 218.11 MB/s

on the desktop:

2021-05-01 09:37:01 Single thread SHA256 performance is 2013 MB/s using minio/sha256-simd (498 MB/s using crypto/sha256).
2021-05-01 09:37:02 Hashing performance is 1185.56 MB/s

What’s the hardware configuration of your VM in Proxmox?

This is the VM: image

Let me know if you were asking for other information? :upside_down_face:

There is non-trivial overhead per file which will affect the over all transfer rate, but to be honest 80Mbps is not too bad, given you on a 100Mbps lan.

I guess you can try creating a single large file and see if the speeds are any better.

Wait, that would make totally sense. :grin:

That’s almost embarrassing, I don’t know my LAN’s speed, because it “came with the apartment”. So it might not be Gigabit. I’ll have to check somehow, because the router is not easily accessible.

Okay, I just stopped everything and started copying a large file via SAMBA. 11.4MB/s. So it seems that everything is fine and my router is just slow. Sorry! :confused:

1 Like

For a Linux guest i’d always use CPU type host.

Do you have server/client connected via LAN? 11.4MB/s is a good indicator for 100Mb/s ethernet connection. If that’s the case you should check which ports of your router offer gigabit ethernet.

What’s the advantage of doing that?

Yes, they are connected via LAN. Unfortunately I think none of my routers ports offers gigabit and additionally the router is not in my “control” to be exchanged for a better one. So I am stuck at that speed, but this is fine as these big file transfers will not happen very often. At least everything is behaving as it should. :slight_smile:

The default CPU type has a reduced set of features in order to guarantee maximum compatibility when moving to another host. The host setting will mimic the features of the host CPU and might provide better performance if they can be used by the guest.

Alright, thanks for explaining and helping out. I really appreciate it! :slight_smile:

Well, no. Connect your machines to a gigabit switch which you also connect to the router. That will give your machines full gigabit speed between them.

Thanks martin, I even thought about doing that, but the router is in a small box (think electrical fuse box) hidden in the wall, and there is only little physical space left there. But that’s fine, like I said it is okay if it stays like that. But good idea!