Syncthing seems to be down, or there is a problem with your Internet connection.

I get the above-referenced message frequently, but the connections seem fast and solid (four bars). I see posts from 2015-16, but no solutions. Elsewhere I’ve found the suggestion to lengthen ping timeouts in Advanced/Options, but I don’t find such settings there. This is mostly an irritant, causing the red message to flash briefly and frequently. Connections and synching seem to be working. The issue has been around for several years. There must be a simple solution that I’m missing.

That message only relates to the connection between Syncthing and your browser. Are they running on the same system? Is the machine running Syncthing possibly very low-powered or otherwise quite busy? Check CPU and RAM usage there, that might delay a response from the backend so much that the browser shows the timeout message.

Andre, my setup is complicated and that may be contributing to the message. This is all in a server running an Intel i7-13700K with 128G of RAM. RAM usage is at 47% and CPU usage is under 2%. Those can be higher, but I get the message even when utilization is low. On the server, I’m running Proxmox with two Windows VMs and TrueNAS Scale also as a VM. Syncthing is loaded onto all three of those. Syncthing on TrueNAS uses the TrueNAS app for Syncthing. All three are connected to the same Linux Bridge on Proxmox (i.e., same subnet). I’m using a browser (Edge) on one of the Windows VMs to access the Syncthing UI on TrueNAS and to access the UIs for the Syncthing instances on the two Windows VMs. The message does not appear in the Syncthing UI on either of the Windows VMs, only on the Syncthing UI for the instance on TrueNAS scale. Any thoughts?

Is there a way to increase ping timeouts?

How does Microsoft Edge on one of the Windows VMs get to Syncthing’s web GUI on the TrueNAS VM?

Which network interfaces was Syncthing in the Docker container on the TrueNAS Scale configured to listen on?

Without more details, best guess is that there’s a high latency issue.

May be possible through setting the STGUIASSETS environment variable and pointing it to a path with a copy of the respective GUI source code file. Can’t say from the top of my head where the timeout is defined, but I’d probably start searching in syncthingController.js. Note that you need to match the existing GUI directory structure in your custom GUI assets directory.

Oh and of course this will possibly break with each update. If you know how, you’re welcome to file a PR to make the timeout configurable.

Andre, thanks for your response. It’s probably more than I’d want to attempt, and I don’t think I need to do that now, given the following sentences. Gadget, your first question was inciteful. The address I used on Edge was [IP address of TrueNAS]:20910. However, I had set up the Syncthing GUI for HTTPS and used HAProxy on pfSense to associate a certificate with it so that Edge would store the username and password. So I was actually using a FQDN with the Backend in HAProxy pointing to the IP address:20910. I removed the checkmark from HTTPS in the Syncthing settings for the GUI and made adjustments in the HAProxy Backend to match. That solved the problem. Now I’m just using [IP address of TrueNAS]:20910 directly, bypassing HAProxy, and not getting the message. Thanks again for your help. (You solved a previous problem for me.) I now recognize that this is not a Syncthing problem but is related to my use of HAProxy to associate a certificate with the FQDN address. That apparently caused the delay.

Update: Removing the checkmark from HTTPS in the Syncthing settings for the GUI and making adjustments in the HAProxy Backend did not work. The message started coming back and eventually at the same frequency. Bypassing HAProxy entirely does work. So it is HAProxy itself that is causing the delay.

HAproxy config?

Generally, when using a proxy, the problem is that the proxy doesn’t like our long running event polling requests. It times out towards the Syncthing backend and returns an error to the client frontend, triggering the error dialog in the frontend. Increasing proxy timeouts will help.

bt90 and calmh, thanks for your comments. I changed the two timeout settings (Connection and Server) in the HAProxy backend for Syncthing from 30 seconds to 60 seconds. I received the message at a regular 60 second interval. So I chanaged them again to 120 seconds, and that seems to have solved the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.