Syncthing running nicely in 'Puppy' Linux...


#1

Evening, all.

I discovered Syncthing yesterday morning, following a link from the tech site MakeUseOf…and thought I’d give it a go.

I’ve tried various syncing apps in the past, and never got on too well with 'em. But, not being one to give up without a fight :grin: , I decided to have another try…

This thing is brilliant! It’s fired up with no complaints on every Pup in my ‘kennels’. Despite the settings all looking rather intimidating, within 10 mins or so I’d got everything set-up on my first Pup (I run about 10 of them, across two different machines on a home LAN), and proceeded to start with one Pup on the other machine.

This is where things get interesting, and shows how versatile Puppy can be…and Syncthing fits right in beautifully. I keep all my personal data folders on a remote partition, symlinked into Pup’s /root folder (Puppy runs as root all the time, of course, since it’s not a true multi-user system).

I also run multiple apps remotely from this same partition, again sym-linked into Pup’s file-system at the appropriate places. I’ve set a single instance of the extracted Syncthing folder here in this partition, and sym-linked it into Pup’s /root folder…and further sym-linked the ‘syncthing’ binary into the /root/Startup folder, to start it at every boot.

The ‘Sync’ folder has been created in this partition (with the path specified in the ‘Local device’ settings), and my data folders moved inside of it. This enables Syncthing to sync all of these folders together. I’ve then re-symlinked these folders back into /root for easy access. This all works beautifully!

I’ve pretty much set things up the same on the other machine.

Thanks so much for this. For the first time ever, I can now save anything to any folder, in any Pup, on either machine…safe in the knowledge that whenever I need to, I can access it whenever I need to on the other machine.

Grazi, mi amigos!

MiqW. :wink: