Syncthing preventing suspend (Linux)

I am having the same problem that was expressed Here, where Syncthing Refuses to freeze when syncing to a separate drive, But addingx-systemd.automount to /etc/fstab to allow his solution to work results in the drive being mounted as read-only. How do i suspend with Syncthing syncing with a separate hard drive?

fstab line in question:

/dev/disk/by-uuid/1C209DE8209DC8E2 /mnt/data auto nosuid,nodev,nofail,x-gvfs-show 0 0

What does this mean; what are we supposed to do?

Sorry i didn’t make myself clear. that term was taken directly from the system log. here’s a portion of it, though keep in mind that the bottom line is the oldest message.

Nov 23 13:42:31 kernel: PM: suspend exit
Nov 23 13:42:31 kernel: audit: type=1400 audit(1637700151.899:18236): apparmor="DENIED" operation="ptrace" profile="snap.discord.discord" pid=3079 comm="Discord" requested_mask="read" denied_mask="read" peer="unconfined"
Nov 23 13:42:31 kernel: kauditd_printk_skb: 82 callbacks suppressed
Nov 23 13:42:31 kernel: Restarting tasks ... done.
Nov 23 13:42:31 kernel: OOM killer enabled.
Nov 23 13:42:31 kernel: 
Nov 23 13:42:31 kernel: R13: 0000000000000045 R14: 0000000000000044 R15: 00000000000000aa
Nov 23 13:42:31 kernel: R10: 0000000000000100 R11: 0000000000000216 R12: ffffffffffffffff
Nov 23 13:42:31 kernel: RBP: 000000c003ecdc20 R08: 0000000000000000 R09: 0000000000000000
Nov 23 13:42:31 kernel: RDX: 000000c002fc4c68 RSI: 000000c0003accc0 RDI: ffffffffffffff9c
Nov 23 13:42:31 kernel: RAX: ffffffffffffffda RBX: 000000c000044000 RCX: 00000000004b961a
Nov 23 13:42:31 kernel: RSP: 002b:000000c003ecdba8 EFLAGS: 00000216 ORIG_RAX: 0000000000000106
Nov 23 13:42:31 kernel: RIP: 0033:0x4b961a
Nov 23 13:42:31 kernel:  entry_SYSCALL_64_after_hwframe+0x44/0xa9
Nov 23 13:42:31 kernel: Call Trace:
Nov 23 13:42:31 kernel: task:syncthing       state:D stack:    0 pid: 4514 ppid:  2162 flags:0x00004004
Nov 23 13:42:31 kernel: Freezing of tasks failed after 20.004 seconds (1 tasks refusing to freeze, wq_busy=0):
Nov 23 13:42:11 kernel: Filesystems sync: 0.024 seconds
Nov 23 13:42:11 kernel: PM: suspend entry (s2idle)
Nov 23 13:42:11 kernel: done.
Nov 23 13:42:11 kernel: audit: type=1400 audit(1637700131.708:18151): apparmor="DENIED" operation="ptrace" profile="snap.discord.discord" pid=3079 comm="Discord" requested_mask="read" denied_mask="read" peer="unconfined"
Nov 23 13:42:11 kernel: kauditd_printk_skb: 82 callbacks suppressed
Nov 23 13:42:11 kernel: Restarting tasks ... 
Nov 23 13:42:11 kernel: OOM killer enabled.
Nov 23 13:42:11 kernel: 

This will be due to your storage driver/filesystem. Syncthing doesn’t do anything to prevent sleep/suspend, its the filesystem that does that in this case.

I was experiencing the same or similar issue.

Audrius is correct - disabling syncthing service has no effect and the system was still unable to suspend.

This seems to be a kernel issue, reverting to a different kernel allowed my system to suspend correctly.

1 Like