syncthing only working via LAN


(Jörg) #1

Hey everybody. I am new here and happy to find a community about syncthing. I’m using ST to keep a raspberry pi (raspbian), a PC and a laptop in sync (both ubuntu). Everything is working very well, as long as I’m in my LAN at home. If I leave the network with my laptop, both other machines get the status ‘disconnected’ (german: “Getrennt”). The machines at home also show the laptop as ‘disconnected’. I connected the machines via ID and only use “dynamic” for adresses. Am I doing something wrong? Thank you for any ideas!


(Audrius Butkevicius) #2

What is discovery and relays showing for all devices? Also, when you move out of LAN it might take some time for connections to be established.


(Jörg) #3

Sorry for responding so late…

When I left LAN:

That is what I see on my Laptop:

PC (gets connected after waiting about 10 minutes!!)

dynamic

relay://...:22067

tcp://...:22000

tcp://[*************]

raspberry (stays disconnected even after waiting really long)

dynamic

On my PC the Laptop has only an ip (no tcp or relay are shown) - but connects after waiting. Here the pi gets an adress in cryptic style like [fe80::…%enp… PC and Pi are connected via LAN

Discovery is set global and local for all devices.

Does this help?


(Jakob Borg) #4

Totally redacted so doesn’t say much. Ten minutes usually means relaying. Lack of info on one side means that side doesn’t get discovery data. Cryptic address sounds like local IPv6, which is the one good thing here.


(Jörg) #5

Did not know how much information about the ips would be good in a forum. If you need more, I can give you more! Screenshots?


(Jörg) #6

Sorry, but I am only allowed to upload one image a post. So you’ll get 4 posts

TUX is the Laptop

As you can see, only dynamic is mentioned for adress of the Pi.


(Jörg) #7

Now midgard (my PC) - part 1


(Jörg) #8

midgard part 2


(Jörg) #9

And that is what syncthing is showing on my raspberrypi


(Jakob Borg) #10
  • midgard doesn’t see tux (or vice versa), so they are connected via relay.
  • midgard sees raspberrypi (or vice versa), so they have a local connection
  • raspberrypi doesn’t see tux, at all, and has no connection to it.

My guesses are

  • Something is odd with tux. Local firewall? Some docker installation with network issues? There’s no screenshot.
  • It’s odd that raspberrypi doesn’t see anything about tux. Have you disabled global discovery?

(Noah Park) #11

I’m having this issue as well. Its always worked for me in the past, but today when I tried to setup syncthing between 2 new computers (1 in California and 2nd in London), no matter what I did I could not get them to see one another. I tried using default relays and discovery servers as well as custom ones. The defaults started working, but still cant get the custom ones…


(Jörg) #12

No Local firewall, no docker installation! Global discovery is activated for every machine.


(Jakob Borg) #13

@noahpark233 There haven’t been any relevant changes to those parts in a long time, afaik. For your custom stuff I think you need to troubleshoot it yourself unfortunately.

@maliers Then I don’t know.


#14

Your raspberry has some listener and/or discovery failures (seen by the 1/2 and 3/5 on Zuhörer und Gerätesuche). If you click on these you may see error messages. What do these say?

Also, may I ask some more details about your network setup and used routers? There appears something to be broken in your network.


(Jörg) #15

Hi @Nummer378 Thanks for your reply. Indeed there are these mentioned errors (did not even realize, I can klick on it) Here is the first. The second comes in next post!

I use a FritzBox 6490Cable, IPs via DHCP, the Pi uses WLAN, the PC LAN
The configuration of the router is quite “unmodified” - only normal end-user-settings.


(Jörg) #16

Here is the second error-message (hovering “Zuhörer”)


(Audrius Butkevicius) #17

You rpi is either misconfigured or on a completely messed up network, or under insane load. It cannot connect to some vital services.


#18

Yes I know this is kind of a “hidden” feature :slight_smile:

Soo, from looking at this it seems your raspberry is totally unable to access servers in the internet (both IPv4 and IPv6). As Audrius already said, this is likely due to some misconfiguration - have you double checked that your raspberry can access the internet (test via browser)? Your PI should be able to reach at least https://discovery-v4.syncthing.net/v2/.