Syncthing on Synology - permission denied

I am a new Syncthing user trying to set up a simple link with a Windows PC and Synology NAS. I have been trying to do this for the past few days but just seem to be getting nowhere. I have scoured the documentation, looked at several videos, and searched the forum where there are many posts on this topic but no solutions to my problem.

Here’s the situation - on the NAS I am getting the following notifications:

Loading ignores: lstat /volume1/Plex/Test/.stignore: permission denied Failed to create folder root directory stat /volume1/Plex/Test: permission denied Error on folder “Test” (test): stat /volume1/Plex/Test: permission denied

I have checked the ‘ignore permissions’ box under the advanced tab and tried to set permissions on the folder using File Station for user sc-syncthing as suggested elsewhere. My problem is that I cannot find user sc-syncthing!

On the Windows PC the folder Test is showing as ‘Up To Date’, but on the NAS it’s ‘Stopped’.

Both sides are set up as Send/Receive, and the Syncthing was downloaded and installed from the community package.

I have tried all sorts before coming to this forum for help, but I hope some kind soul can suggest a solution to what seems like a basic problem. I think I must be missing something…

Many thanks in advance :smile:

Synology has a particular and interesting system for permissions. There have been a few other similar threads about this previously.

Thank you for your reply Jakob. I checked through the similar threads using the link you provided. I had tried all which seemed relevant but most had not been declared as resolved so I re-installed Syncthing, noting the information about permissions during installation.

I was sure that my issue concerned the user sc-syncthing, which I couldn’t find before and was referenced often in the previous threads.

I read the permissions management guide:

which helped me find a different approach to resolve this: On the NAS, using Control Panel/Shared Folder, I right clicked on Plex folder, selected edit then permissions and changed ‘local users’ to ‘system internal user’. Now user sc-syncthing was shown! I selected read/write for sc-syncthing and this resolved the permission denied problem. :smiley:

Here’s a screenshot which might help other users experiencing similar permissions issues.

Thanks again for helping me become a happy syncthing user.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.